Custom entity does not appear after importing a solution

This article provides a solution to an issue where custom entities don't display after importing a solution.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2500942

Symptoms

After importing a solution into another organization, the custom entity doesn't show up.

Cause

It happens when the solution doesn't have SiteMap as a component.

It also can happen if you don't publish your customizations after importing the solution.

Resolution

Resolution 1:

Include SiteMap as part of the solution and re-export the solution. Then import the solution into another organization.

  1. Select Settings, select Solutions, and open the solution you want to modify.
  2. Select Client Extensions, select Add Existing, and choose Site Map.
  3. Select Save.
  4. Select Export Solution and follow the export wizard to export your solution.

Resolution 2:

Customize the imported custom entity on the organization where the solution has been imported, to show the entity in the area you want like Workplace.

  1. Select Settings, select Customizations, and select Customize the System.
  2. Under Components, expand Entities, and select the entity you want to modify.
  3. Under the Areas that display this entity, select the areas to display the custom entity.

Resolution 3:

Publish All Customizations:

  1. Select Settings, select Customizations, and select Customize the System.
  2. Select Publish All Customizations.

Publish just the custom entity:

  1. Select Settings, select Customizations, and select Customize the System.
  2. Under Components, expand Entities and select the entity you want to publish.
  3. Select Publish on the ribbon.