Řešení potíží s centrem pro správu aktualizací (Preview)
Tento článek popisuje chyby, ke kterým může dojít při nasazení nebo použití centra pro správu aktualizací (Preview) a jejich řešení.
Obecné řešení potíží
Následující kroky pro řešení potíží platí pro virtuální počítače Azure související s rozšířením oprav na počítačích s Windows a Linuxem.
Virtuální počítač Azure s Linuxem
Pokud chcete ověřit, jestli je spuštěný agent virtuálního počítače Microsoft Azure( agent virtuálního počítače), aktivoval na počítači příslušné akce a pořadové číslo žádosti o automatickoupatí, zkontrolujte v protokolu agenta další podrobnosti v /var/log/waagent.log
. Každý požadavek automatického zápatí má přiřazené jedinečné pořadové číslo na počítači. Vyhledejte protokol podobný: 2021-01-20T16:57:00.607529Z INFO ExtHandler
.
Adresář balíčku pro příponu je /var/lib/waagent/Microsoft.CPlat.Core.Edp.LinuxPatchExtension-<version>
a v /status
podsložce je <sequence number>.status
soubor, který obsahuje stručný popis akcí provedených během jednoho požadavku automatickéhopatí a stav. Obsahuje také krátký seznam chyb, ke kterým došlo při instalaci aktualizací.
Pokud chcete zkontrolovat protokoly související se všemi akcemi provedenými rozšířením, zkontrolujte další podrobnosti v tématu /var/log/azure/Microsoft.CPlat.Core.Edp.LinuxPatchExtension/
. Obsahuje následující dva soubory protokolů, které jsou zajímavé:
<seq number>.core.log
: Obsahuje podrobnosti související s akcemi oprav, jako jsou opravy vyhodnocené a nainstalované na počítači, a všechny problémy, ke kterým došlo v procesu.<Date and Time>_<Handler action>.ext.log
: Nad akcí opravy existuje obálka, která slouží ke správě rozšíření a vyvolání konkrétní operace opravy. Tento protokol obsahuje podrobnosti o obálku. U automatickéhopatí obsahuje podrobnosti o tom,<Date and Time>_Enable.ext.log
jestli byla vyvolána konkrétní operace opravy.
Virtuální počítač Azure s Windows
Pokud chcete ověřit, jestli je spuštěný agent virtuálního počítače Microsoft Azure( agent virtuálního počítače), aktivoval na počítači příslušné akce a pořadové číslo žádosti o automatickoupatí, zkontrolujte v protokolu agenta další podrobnosti v C:\WindowsAzure\Logs\AggregateStatus
. Adresář balíčku rozšíření je C:\Packages\Plugins\Microsoft.CPlat.Core.WindowsPatchExtension<version>
.
Pokud chcete zkontrolovat protokoly související se všemi akcemi provedenými rozšířením, zkontrolujte další podrobnosti v tématu C:\WindowsAzure\Logs\Plugins\Microsoft.CPlat.Core.WindowsPatchExtension<version>
. Obsahuje následující dva soubory protokolů, které jsou zajímavé:
WindowsUpdateExtension.log
: Obsahuje podrobnosti související s akcemi oprav, jako jsou opravy vyhodnocené a nainstalované na počítači, a všechny problémy, ke kterým došlo v procesu.CommandExecution.log
: Nad akcí opravy existuje obálka, která slouží ke správě rozšíření a vyvolání konkrétní operace opravy. Tento protokol obsahuje podrobnosti o obálku. Protokol obsahuje podrobnosti o tom, jestli byla vyvolána konkrétní operace opravy.
Servery s podporou oblouku
V případě serverů s podporou arc si projděte článek o řešení potíží s rozšířeními virtuálních počítačů, kde najdete obecné kroky pro řešení potíží.
Pokud chcete zkontrolovat protokoly související se všemi akcemi provedenými rozšířením, zkontrolujte v systému Windows další podrobnosti v C:\ProgramData\GuestConfig\extension_Logs\Microsoft.SoftwareUpdateManagement\WindowsOsUpdateExtension
tématu . Obsahuje následující dva soubory protokolů, které jsou zajímavé:
WindowsUpdateExtension.log
: Obsahuje podrobnosti související s akcemi oprav, jako jsou opravy vyhodnocené a nainstalované na počítači, a všechny problémy, ke kterým došlo v procesu.cmd_execution_<numeric>_stdout.txt
: Nad akcí opravy existuje obálka, která slouží ke správě rozšíření a vyvolání konkrétní operace opravy. Tento protokol obsahuje podrobnosti o obálku. Protokol obsahuje podrobnosti o tom, jestli byla vyvolána konkrétní operace opravy.cmd_excution_<numeric>_stderr.txt
Známé problémy
Scénář: Spuštění opravy se nezdařilo s překročeným oknem údržby zobrazující hodnotu true i v případě, že zůstal čas
Problém
Když zobrazíte nasazení aktualizace v historii aktualizací, vlastnost Selhání s časovým intervalem údržby se zobrazítrue , i když byl dostatek času na spuštění. V tomto případě je možné provést jednu z následujících možností:
- Nezobrazují se žádné aktualizace.
- Nejméně jedna aktualizace je ve stavu Čeká na vyřízení .
- Stav restartování je povinný, ale restartování se nepokoušelo ani v případě, že bylo nastavení restartování předáno
IfRequired
neboAlways
.
Příčina
Během nasazování aktualizací kontroluje využití časového období údržby v několika krocích. Deset minut časového období údržby je rezervováno pro restartování v libovolném okamžiku. Před získáním seznamu chybějících aktualizací nebo stažením/instalací jakékoli aktualizace (kromě aktualizací Aktualizace Service Pack systému Windows) zkontroluje, jestli je restartování 15 minut + 10 minut (to znamená 25 minut zbývá v časovém období údržby). V případě aktualizací service Pack pro Windows zkontrolujeme 20 minut + 10 minut pro restartování (to znamená 30 minut). Pokud nasazení nemá dostatek vlevo, přeskočí kontrolu, stažení a instalaci aktualizací. Nasazení se spustí a zkontroluje, jestli je potřeba restartovat počítač a jestli v časovém období údržby zbývá deset minut. Pokud existuje, nasazení aktivuje restartování, jinak se restartování přeskočí. V takovýchpřípadechch V případech, kdy zbývá čas kratší než 25 minut, se aktualizace nenaskenují nebo se nepokouší o instalaci.
Další podrobnosti najdete v protokolech v cestě k souboru uvedené v chybové zprávě o spuštění nasazení.
Řešení
Nastavení delšího časového rozsahu pro maximální dobu trvání při aktivaci nasazení aktualizací na vyžádání pomáhá vyhnout se problému.
Další kroky
- Další informace o centru pro správu služby Azure Update (Preview) najdete v přehledu.
- Pokud chcete zobrazit protokolované výsledky ze všech počítačů, přečtěte si téma Dotazování protokolů a výsledků z centra pro správu aktualizací (Preview).