Sdílet prostřednictvím


Skupina zabezpečení nemá přístup k veřejné složce v Exchangi Online

Příznaky

Členové skupiny zabezpečení nemají přístup k veřejné složce v Exchangi Online, i když se zdá, že skupina zabezpečení má příslušná přístupová práva.

Například rutina Prostředí PowerShell Get-PublicFolderClientPermission vygeneruje následující výstup.

Snímek obrazovky s výstupem rutiny Get-PublicFolderClientPermission

Výstup ukazuje, že Security group1 má přístupová práva PublishingEditoru k veřejné složce. Pokud se však členové skupiny zabezpečení pokusí vytvořit, přesunout nebo odstranit podsložku ve veřejné složce, zobrazí se jim chybová zpráva, která značí nedostatek oprávnění.

Příčina

K tomuto problému dochází, pokud se identifikátor zabezpečení objektu skupiny zabezpečení v ID Microsoft Entra změní poté, co je skupině udělen přístup k veřejné složce. Pokud se identifikátor zabezpečení změní, skupina zabezpečení se už nebude shodovat s položkou v seznamu přístupových práv pro veřejnou složku. Proto i když je položka skupiny zabezpečení stále v seznamu přístupových práv, členové skupiny zabezpečení již nebudou mít přístup k veřejné složce.

Poznámka

Pokud chcete zkontrolovat hodnotu identifikátoru zabezpečení skupiny zabezpečení, spusťte v Exchange Online PowerShellu následující příkazy:

$permissions = Get-PublicFolderClientPermission -Identity "<public folder>" -User "<security group name>"
$permissions.User.RecipientPrincipal | FL DisplayName, Sid

Oba následující scénáře způsobí změnu identifikátoru zabezpečení.

Scénář 1

Krok 1: Vytvoříte skupinu zabezpečení na Exchange Serveru a pak provedete synchronizaci z místní služby Active Directory do Microsoft Entra ID. Skupina zabezpečení s povolenou poštou se zobrazí v Exchange Online.

Krok 2: Ve službě Exchange Online udělíte skupině zabezpečení přístupová práva k veřejné složce v Exchangi Online. Členové skupiny zabezpečení teď mají přístup k veřejné složce.

Krok 3: Odstraníte místní skupinu zabezpečení v místní službě Active Directory.

Krok 4: Obnovíte místní skupinu zabezpečení v místní službě Active Directory a pak znovu synchronizujete místní službu Active Directory na Microsoft Entra ID.

Po dokončení kroku 4 už členové skupiny zabezpečení nebudou mít přístup k veřejné složce.

Scénář 2

Krok 1: Vytvoříte skupinu zabezpečení s podporou pošty v Exchangi Online.

Krok 2: Skupině zabezpečení udělíte přístupová práva k veřejné složce v Exchangi Online. Členové skupiny zabezpečení teď mají přístup k veřejné složce.

Krok 3: Skupinu zabezpečení odstraníte.

Krok 4: V Exchangi Online vytvoříte novou poštovní skupinu zabezpečení, která má stejný název jako odstraněná skupina zabezpečení.

Po dokončení kroku 3 už členové skupiny zabezpečení nebudou mít přístup k veřejné složce. Po dokončení kroku 4 členové skupiny zabezpečení znovu nezískají přístup.

Řešení

Pokud chcete tento problém vyřešit, aktualizujte skupinu zabezpečení v seznamu přístupových práv pro veřejnou složku následujícím postupem:

  1. Spuštěním následující rutiny v Prostředí Exchange Online PowerShell odeberte přístupová práva k veřejným složkám pro původní skupinu zabezpečení:

    Remove-PublicFolderClientPermission -Identity "<public folder>" -User "<security group name>"
    
  2. Spuštěním následující rutiny v Exchange Online PowerShellu přidejte přístupová práva k veřejným složkám pro obnovenou nebo novou skupinu zabezpečení:

    Add-PublicFolderClientPermission -Identity "<public folder>" -User "<security group name>" -AccessRights "<access rights>"
    

Například rutiny Prostředí PowerShell Remove-PublicFolderClientPermission a Add-PublicFolderClientPermission vygenerují následující výstup.

Snímek obrazovky s výstupem rutin Remove-PublicFolderClientPermission a Add-PublicFolderClientPermission