Po přesunutí vzdálené poštovní schránky z místního prostředí Exchange Server do Microsoftu 365 nejde získat přístup k poštovní schránce pomocí Outlooku
Příznaky
Po přesunutí poštovní schránky uživatele z místního prostředí Microsoft Exchange Server do Microsoftu 365 nebude mít uživatel přístup k poštovní schránce pomocí Microsoft Outlooku. Uživatel ale má přístup k poštovní schránce pomocí Outlook Web App.
Kromě toho se v Konzola pro správu serveru Exchange může zobrazit chybová zpráva podobná následující po neúspěšném přesunu vzdálené poštovní schránky:
<Datum><a čas> [<] Po>>< přesunutí se nepodařilo převést zdrojovou poštovní schránku Primární (00000000-0000-0000-0000-0000-000000000000000000)' na uživatele pošty. Pokus 6/6. Chyba: UpdateMovedMailboxPermanentException.
Příčina
K tomuto problému může dojít, pokud zakážete dědičnost oprávnění u cílového uživatele ve schématu místní Active Directory.
Proto i když je místní poštovní schránka uživatele označená jako přesunutá v Exchange Server, nepřeveďte ji na vzdálenou poštovní schránku uživatele podle očekávání. Místní poštovní schránka uživatele nadále obsahuje obvyklého uživatele s povolenou poštovní schránkou.
Řešení
Pokud chcete tento problém vyřešit, postupujte takto:
Identifikujte všechny vlastnosti uživatele v poštovní schránce a pak tyto informace uložte do textového souboru. Chcete-li to provést, otevřete prostředí Exchange Management Shell a spusťte následující příkaz:
Get-Mailbox <UserMailbox> | fl | Out-File C:\UserMailbox.txt
Zakažte místní poštovní schránku uživatele. Chcete-li to provést, použijte jednu z následujících metod:
- Pomocí Konzola pro správu serveru Exchange zakažte místní poštovní schránku uživatele.
- Pomocí prostředí Exchange Management Shell zakažte místní poštovní schránku uživatele. Chcete-li to provést, spusťte následující příkaz prostředí Exchange Management Shell:
Disable-Mailbox <UserMailbox>
Další informace o této rutině najdete v tématu Zakázání poštovní schránky.
Převeďte místní poštovní schránku uživatele na poštovní schránku vzdáleného uživatele. Chcete-li to provést, spusťte následující rutinu prostředí Exchange Management Shell:
Enable-RemoteMailbox -Identity <UserName> -RemoteRoutingAddress <UserName@domain.mail.onmicrosoft.com>
Po zřízení vzdálené poštovní schránky upravte všechny vlastní atributy poštovní schránky (například
legacyExchangeDN
atribut), které chcete a které nebyly přiřazeny zásadami e-mailové adresy k uživatelskému účtu.
Další informace
Poznámka
V systému Microsoft Exchange 2010 se vzdálená poštovní schránka skládá z uživatele pošty, který existuje v místní Active Directory, a přidružené poštovní schránky, která existuje v cloudové službě.
Další informace o rutinách uvedených v tomto článku najdete tady:
Stále potřebujete pomoc? Přejděte na web Microsoft Community.