Psání a spouštění skriptů v prostředí Windows PowerShell ISE

Tento článek popisuje, jak vytvářet, upravovat, spouštět a ukládat skripty v podokně skriptů.

Vytváření a spouštění skriptů

Soubory Windows PowerShell můžete otevřít a upravit v podokně skriptů. Konkrétní typy souborů, které mají zájem o Windows PowerShell, jsou soubory skriptů (.ps1), datové soubory skriptů (.psd1) a soubory modulů skriptu (.psm1). Tyto typy souborů jsou v editoru podokna skriptů barevné. Další běžné typy souborů, které můžete otevřít v podokně skriptů, jsou konfigurační soubory (.ps1xml), soubory XML a textové soubory.

Poznámka

Zásady spouštění Windows PowerShell určují, jestli můžete spouštět skripty a načítat profily Windows PowerShell a konfigurační soubory. Výchozí zásady spouštění s omezeným přístupem brání spuštění všech skriptů a brání načítání profilů. Pokud chcete změnit zásady spouštění tak, aby se profily mohly načítat a používat, přečtěte si téma Set-ExecutionPolicy a about_Signing.

Vytvoření nového souboru skriptu

Na panelu nástrojů klikněte na Nový nebo v nabídce Soubor klikněte na Nový. Vytvořený soubor se zobrazí na nové kartě souboru na aktuální kartě PowerShellu. Mějte na paměti, že karty PowerShellu jsou viditelné jenom v případech, kdy jich existuje více. Ve výchozím nastavení se vytvoří soubor typu skriptu (.ps1), ale dá se uložit s novým názvem a příponou. Na stejné kartě PowerShellu je možné vytvořit více souborů skriptů.

Otevření existujícího skriptu

Na panelu nástrojů klikněte na Otevřít nebo v nabídce Soubor klikněte na Otevřít. V dialogovém okně Otevřít vyberte soubor, který chcete otevřít. Otevřený soubor se zobrazí na nové kartě.

Zavření karty skriptu

Klikněte na ikonu Zavřít (X) na kartě souboru, kterou chcete zavřít, nebo vyberte nabídku Soubor a klikněte na Zavřít.

Pokud se soubor od posledního uložení změnil, zobrazí se výzva k jeho uložení nebo zahození.

Zobrazení cesty k souboru

Na kartě soubor přejděte na název souboru. Plně kvalifikovaná cesta k souboru skriptu se zobrazí v popisu.

Spuštění skriptu

Na panelu nástrojů klepněte na příkaz Spustit skript nebo v nabídce Soubor klepněte na tlačítko Spustit.

Spuštění části skriptu

  1. V podokně skriptů vyberte část skriptu.
  2. V nabídce Soubor klepněte na tlačítko Spustit výběr nebo na panelu nástrojů klepněte na tlačítko Spustit výběr.

Zastavení spuštěného skriptu

Spuštěný skript můžete zastavit několika způsoby.

  • Na panelu nástrojů klikněte na Zastavit operaci.
  • Stiskněte CTRL+BREAK.
  • Vyberte nabídku Soubor a klikněte na Zastavit operaci.

Stisknutí kombinace kláves CTRL+C také funguje, pokud není aktuálně vybraný nějaký text, v takovém případě se ctrl+C mapuje na funkci kopírování pro vybraný text.

Jak psát a upravovat text v podokně skriptů

Text můžete kopírovat, vyjmout, vložit, najít a nahradit v podokně skriptů. Můžete také vrátit zpět a znovu provést poslední akci, kterou jste právě provedli. Klávesové zkratky pro tyto akce jsou stejné klávesové zkratky, které se používají pro všechny aplikace pro Windows.

Zadání textu do podokna skriptů

  1. Přesuňte kurzor do podokna skriptů kliknutím na libovolné místo v podokně skriptů nebo kliknutím na Přejít do podokna skriptů v nabídce Zobrazení .
  2. Vytvořte skript. Barevné obarvení syntaxe a dokončování tabulátoru poskytují bohatší prostředí pro úpravy v Windows PowerShell ISE.
  3. Podrobnosti o použití funkce dokončování tabulátoru najdete v podokně skriptů a podokně konzoly , která vám pomůže při psaní pomocí funkce dokončování tabulátoru.

Vyhledání textu v podokně skriptů

  1. Pokud chcete najít text kdekoli, stiskněte klávesu CTRL+F nebo v nabídce Upravit klikněte na Najít ve skriptu.
  2. Pokud chcete najít text za kurzorem, stiskněte klávesu F3 nebo v nabídce Upravit klepněte na tlačítko Najít další ve skriptu.
  3. Pokud chcete najít text před kurzorem, stiskněte shift+F3 nebo v nabídce Upravit klikněte na Najít předchozí ve skriptu.

Vyhledání a nahrazení textu v podokně skriptů

Stiskněte klávesu CTRL+H nebo v nabídce Upravit klepněte na tlačítko Nahradit ve skriptu. Zadejte text, který chcete najít, a náhradní text a stiskněte enter.

Přechod na konkrétní řádek textu v podokně skriptů

  1. V podokně skriptů stiskněte klávesu CTRL+G nebo v nabídce Upravit klikněte na Tlačítko Přejít na řádek.

  2. Zadejte číslo řádku.

Kopírování textu v podokně skriptů

  1. V podokně skriptů vyberte text, který chcete zkopírovat.

  2. Stiskněte ctrl+C nebo na panelu nástrojů klikněte na ikonu Kopírovat nebo v nabídce Upravit klikněte na Kopírovat.

Vyjmutí textu v podokně skriptů

  1. V podokně skriptů vyberte text, který chcete vyjmout.
  2. Stiskněte ctrl+X nebo na panelu nástrojů klikněte na ikonu Vyjmout nebo v nabídce Upravit klikněte na Vyjmout.

Vložení textu do podokna skriptů

Stiskněte klávesu CTRL+V nebo na panelu nástrojů klikněte na ikonu Vložit nebo v nabídce Upravit klikněte na Vložit.

Vrácení akce zpět v podokně skriptů

Stiskněte klávesu CTRL+Z nebo na panelu nástrojů klikněte na ikonu Zpět nebo v nabídce Upravit klepněte na tlačítko Zpět.

Opětovné vytvoření akce v podokně skriptů

Stiskněte ctrl+Y nebo na panelu nástrojů klikněte na ikonu Znovu nebo v nabídce Upravit klikněte na Znovu.

Jak uložit skript

Vedle názvu skriptu se zobrazí hvězdička, která označí soubor, který se od změny neuložil. Hvězdička po uložení souboru zmizí.

Uložení skriptu

Stiskněte ctrl+S nebo na panelu nástrojů klikněte na ikonu Uložit nebo v nabídce Soubor klikněte na Uložit.

Uložení a pojmenování skriptu

  1. V nabídce File klikněte na Save As (Uložit jako). Zobrazí se dialogové okno Uložit jako .
  2. Do pole Název souboru zadejte název souboru.
  3. V poli Uložit jako typ vyberte typ souboru. Například v poli Uložit jako typ vyberte PowerShell Scripts (*.ps1).
  4. Klikněte na Uložit.

Uložení skriptu v kódování ASCII

Ve výchozím nastavení Windows PowerShell ISE ukládá nové soubory skriptů (.ps1), datové soubory skriptů (.psd1) a soubory modulů skriptu (.psm1) jako Unicode (BigEndianUnicode). Chcete-li uložit skript do jiného kódování, například ASCII (ANSI), použijte metody Save nebo SaveAs na $psISE.CurrentFile objektu.

Následující příkaz uloží nový skript jako MyScript.ps1 s kódováním ASCII.

$psISE.CurrentFile.SaveAs("MyScript.ps1", [System.Text.Encoding]::ASCII)

Následující příkaz nahradí aktuální soubor skriptu souborem se stejným názvem, ale kódováním ASCII.

$psISE.CurrentFile.Save([System.Text.Encoding]::ASCII)

Následující příkaz získá kódování aktuálního souboru.

$psISE.CurrentFile.encoding

Windows PowerShell ISE podporuje následující možnosti kódování: ASCII, BigEndianUnicode, Unicode, UTF32, UTF7, UTF8 a Default. Hodnota výchozí možnosti se liší od systému.

Windows PowerShell ISE při použití příkazů Uložit nebo Uložit jako nezmění kódování souborů skriptu.

Viz také