Dokumentbausteine fehlen möglicherweise in einer Vorlage, die Teil einer Arbeitsgruppenvorlage in Word 2010 ist

Problembeschreibung

In Microsoft Office Word 2010 fehlen Dokumentbausteine möglicherweise in einer Vorlage, die Teil einer Arbeitsgruppenvorlage ist.

Wichtig

Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Ändern der Registrierung finden Sie unter Windows-Registrierungsinformationen für fortgeschrittene Benutzer.

Ursache

Dieses Problem tritt auf, weil sich der Arbeitsgruppenpfad für Bausteinvorlagen vom Pfad für normale Vorlagen unterscheidet.

Problemumgehung

Wenden Sie eine der folgenden Methoden an, um dieses Problem zu umgehen:

Methode 1

Warnung

Die unsachgemäße Verwendung des Registrierungs-Editors oder einer anderen Methode kann schwerwiegende Probleme verursachen. Diese Probleme können eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft gibt keinerlei Garantien dafür ab, dass diese Probleme behoben werden können. Das Ändern der Registrierung erfolgt auf eigenes Risiko.

Verwenden Sie den Registrierungs-Editor, um den SharedDocumentParts-Schlüssel im folgenden Registrierungsunterschlüssel auf den Pfad der freigegebenen Vorlage festzulegen:

  • Office 2010: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Common

Führen Sie hierfür die folgenden Schritte aus:

  1. Wählen Sie "Start", dann " Ausführen", " regedit" und dann " OK" aus.

  2. Suchen Sie den folgenden Schlüssel in der Registrierung, und wählen Sie den folgenden Schlüssel aus:

    • Office 2010:HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0
  3. Zeigen Sie im Menü "Bearbeiten" auf "Neu", und wählen Sie dann "Taste" aus.

  4. Geben Sie "Allgemein" ein, und wählen Sie dann die EINGABETASTE aus.

  5. Suchen Sie den folgenden Schlüssel in der Registrierung, und wählen Sie den folgenden Schlüssel aus:

    • Office 2010: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0
  6. Zeigen Sie im Menü "Bearbeiten" auf "Neu", und wählen Sie dann "Taste" aus.

  7. Geben Sie "Allgemein" ein, und wählen Sie dann die EINGABETASTE aus.

  8. Zeigen Sie im Menü Bearbeiten auf Neu, und wählen Sie dann Zeichenfolge-Wert aus.

  9. Wählen Sie im Menü Bearbeiten die Option Ändern aus.

  10. Geben Sie "SharedDocumentParts" ein, und wählen Sie dann "OK" aus.

Hinweis

Legen Sie den Wert der Schlüsselzeichenfolge auf \\server\share.

Methode 2

Aktivieren Sie die Gruppenrichtlinie, um den freigegebenen Speicherort für Vorlagen festzulegen. Gehen Sie dazu wie folgt vor:

Hinweis

Die Schritte in Methode 2 führen zu derselben Registrierungseinstellung wie in Methode 1.

  1. Laden Sie die administrativen Vorlagen aus dem Office Resource Kit 2010 herunter, und installieren Sie sie.

  2. Kopieren Sie die Datei "office14.adm " in den Ordner " c:\windows\inf".

  3. Wählen Sie "Start" aus, wählen Sie "Ausführen" aus, geben Sie "gpedit.msc" ein, und wählen Sie dann "OK" aus.

  4. Klicken Sie im Gruppenrichtlinie-Objekt-Editor unter "Benutzerkonfiguration" mit der rechten Maustaste auf "Administrative Vorlagen", und wählen Sie dann "Vorlagen hinzufügen/entfernen" aus.

  5. Wählen Sie im Dialogfeld "Vorlagen hinzufügen/entfernen " die Option "Hinzufügen" aus, geben Sie für Office 2010 " c:\windows\inf\office14.adm " im Feld "Dateiname " ein, und wählen Sie dann " Öffnen" aus.

  6. Wählen Sie "Schließen " aus, um das Dialogfeld "Vorlagen hinzufügen/entfernen " zu schließen.

  7. Erweitern Sie im Gruppenrichtlinie-Objekt-Editor unter "Benutzerkonfiguration" administrative Vorlagen, erweitern Sie das Microsoft Office 2010-System, und wählen Sie dann "Freigegebene Pfade" aus.

  8. Doppelklicken Sie im Bereich "Freigegebene Pfade " auf " Arbeitsgruppen-Buildblockpfad".

  9. Wählen Sie im Dialogfeld " Arbeitsgruppen-Buildblöcke pfad " auf der Registerkarte "Einstellung " das Optionsfeld "Aktivieren " aus, und geben Sie dann die Position der Bausteine in diesem Format ein \\server\share.

Weitere Informationen

Schritte zum Reproduzieren dieses Problems

Führen Sie die folgenden Schritte aus, um dieses Problem zu reproduzieren:

  1. Erstellen Sie eine Vorlage, die einen oder mehrere Bausteine enthält. Gehen Sie dazu wie folgt vor:

    1. Starten Sie Word 2010.

    2. Wählen Sie die Microsoft Office-Schaltfläche und dann " Neu" aus.

    3. Wählen Sie im Dialogfeld "Neues Dokument " die Option "Installierte Vorlagen" aus.

    4. Doppeltippen Sie im Bereich "Installierte Vorlagen" auf einen Vorlagennamen.

    5. Wählen Sie einen Bereich der Vorlage aus, in dem Sie einen Baustein erstellen möchten.

    6. Wählen Sie die Registerkarte "Einfügen ", dann " Schnellbausteine" und dann "Auswahl im Schnellbausteinkatalog speichern" aus.

    7. Geben Sie im Dialogfeld " Neuen Baustein erstellen " " BuildingBlockName " in das Feld "Name " ein.

    8. Wählen Sie im Dropdownfeld "Katalogname" und dann im Dropdownfeld "Kategorie" die Option "Kategoriename" aus.

    9. Wählen Sie den Vorlagennamen aus Schritt d unter dem Dropdownfeld "Speichern in" aus, und wählen Sie dann "OK" aus.

      Hinweis

      Wiederholen Sie die Schritte a bis i, um alle Bausteine zu speichern, die Sie freigeben möchten.

  2. Erstellen Sie eine Ordnerstruktur, z. B. \\server\share, und geben Sie dann den Ordner frei, den Sie für den Speicherort Ihrer Arbeitsgruppe verwenden.

  3. Kopieren Sie die in Schritt 1d erstellte Vorlage in den freigegebenen Ordner, den Sie in Schritt 2 erstellt haben.

  4. Legen Sie die Arbeitsgruppenvorlagen auf den \\server\share Speicherort fest. Gehen Sie dazu wie folgt vor:

    1. Wählen Sie die Microsoft Office-Schaltfläche oder die Registerkarte "Datei" und dann "Word-Optionen" aus.
    2. Wählen Sie im Fenster " Word-Optionen " die Option "Erweitert" und dann "Dateispeicherorte" aus.
    3. Wählen Sie im Dialogfeld "Dateispeicherorte " die Option "Arbeitsgruppenvorlagen" und dann " Ändern" aus.
    4. Geben Sie im Dialogfeld "Speicherort ändern" im Feld "Ordnername" die Zeichenfolge "\\server\share" ein, und wählen Sie dann "OK" aus.
    5. Wählen Sie "OK " aus, um das Dialogfeld "Dateispeicherorte " zu schließen.
  5. Legen Sie Fest, dass Word dem Speicherort vertraut, an dem Vorlagen, die Bausteine enthalten, gespeichert werden. Gehen Sie dazu wie folgt vor:

    1. Wählen Sie Microsoft Office oder Datei und dann Word-Optionen aus.
    2. Wählen Sie im Fenster " Word-Optionen " die Option "Trust Center" und dann " Einstellungen für das Trust Center" aus.
    3. Wählen Sie im Dialogfeld " Trust Center " die Option " Vertrauenswürdige Speicherorte" aus, klicken Sie, um vertrauenswürdige Speicherorte in meinem Netzwerk zuzulassen (nicht empfohlen), und wählen Sie dann "Neuen Speicherort hinzufügen" aus.
    4. Geben Sie im Dialogfeld "Vertrauenswürdiger Speicherort in Microsoft Office 2010 " das Textfeld "\\server\freigeben" in das Textfeld "Pfad " ein, und aktivieren Sie die Option " Unterordner dieses Speicherorts sind ebenfalls vertrauenswürdig", und wählen Sie dann "OK" aus.
    5. Klicken Sie auf "OK ", um das Dialogfeld " Trust Center " zu schließen.
    6. Wählen Sie "OK " aus, um die Word-Optionen zu schließen.