Beim Herstellen einer Verbindung von Microsoft Dynamics 365 mit Exchange Server lokal ist ein Identitätswechselfehler aufgetreten.

Dieser Artikel bietet eine Lösung für das Problem, dass möglicherweise ein Fehler angezeigt wird, der besagt , dass beim Zugriff auf das Postfach beim Senden der E-Mail-Nachricht "Testnachricht" beim Aktivieren eines Postfachs ein Identitätswechselfehler aufgetreten ist.

Gilt für: Microsoft Dynamics CRM
Ursprüngliche KB-Nummer: 3189639

Problembeschreibung

Wenn Server-Side Synchronisierung zwischen Microsoft Dynamics 365 (online) und Microsoft Exchange Server (lokal) konfiguriert ist, erhalten Sie einen der folgenden Fehler, nachdem Sie versucht haben, ein Postfach zu aktivieren:

Beim Zugriff auf das Postfach ist beim Senden der E-Mail-Nachricht "Testnachricht" ein Identitätswechselfehler aufgetreten. Postfach <Der Postfachname> wurde nicht synchronisiert. Der Besitzer des zugeordneten E-Mail-Serverprofils <Email Serverprofilnamens> wurde benachrichtigt.

Beim Zugriff auf das Postfach beim Empfangen von E-Mails ist ein Identitätswechselfehler aufgetreten. <Der Postfachname> wurde nicht synchronisiert. Der Besitzer des zugeordneten E-Mail-Serverprofils <Email Serverprofilnamens> wurde benachrichtigt.

Wenn Sie Details für einen der oben genannten Fehler auswählen, werden möglicherweise Details wie die folgenden angezeigt:

ActivityId: <GUID>
>Fehler: System.Web.Services.Protocols.SoapException: Das Konto verfügt nicht über die Berechtigung zum Annehmen der Identität des angeforderten Benutzers.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
unter Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem(IAsyncResult asyncResult)
bei Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
unter Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()ActivityId: <GUID>
>Fehler: System.Web.Services.Protocols.SoapException: Das Konto verfügt nicht über die Berechtigung zum Annehmen der Identität des angeforderten Benutzers.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
unter Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult asyncResult)
unter Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

Ursache

Dieser Fehler kann auftreten, wenn das für den Zugriff auf das Postfach angegebene Benutzerkonto nicht über Identitätswechselberechtigungen für das Postfach verfügt. Das Konto, das für den Zugriff auf das Postfach verwendet wird, wird im Email Serverprofildatensatz bereitgestellt, der dem Postfachdatensatz in Microsoft Dynamics 365 zugeordnet ist.

Lösung

Stellen Sie sicher, dass das im Email Serverprofildatensatz angegebene Benutzerkonto über Identitätswechselberechtigungen für jedes zugeordnete Postfach verfügt. In einem Postfachdatensatz in Microsoft Dynamics 365 können Sie den Wert Serverprofil auswählen und überprüfen, welches Konto im Abschnitt Anmeldeinformationen des Email Serverprofil-Datensatzes bereitgestellt wird.

Weitere Informationen zum Konfigurieren des Exchange-Identitätswechsels finden Sie unter: