Fehler "Der Datensatz konnte aufgrund einer Zuordnung nicht gelöscht werden" tritt in Microsoft Dynamics 365 auf.
Dieser Artikel enthält eine Lösung für einen Fehler, der beim Versuch auftritt, eine Lösung in Dynamics 365 zu löschen.
Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4459159
Problembeschreibung
Wenn Sie versuchen, eine Lösung in Dynamics 365 zu löschen, wird die folgende Fehlermeldung angezeigt:
"Der Datensatz konnte aufgrund einer Zuordnung nicht gelöscht werden. Der Datensatz kann nicht gelöscht werden, weil er einem anderen Datensatz zugeordnet ist."
Ursache
Dieser Fehler kann auftreten, wenn Sie versuchen, eine Lösung zu löschen, die eine Komponente enthält, die noch von einer anderen Komponente verwendet wird.
Beispiel: Wenn die Lösung eine Bildwebressource enthält und dieses Bild von einem Design verwendet wird, würden Sie diesen Fehler beheben, wenn Sie versuchen, diese Lösung zu löschen.
Lösung
Bevor Sie versuchen, die Lösung zu löschen, entfernen Sie alle Verweise aus den enthaltenen Komponenten auf Komponenten in anderen Lösungen.
Im Beispiel aus dem Abschnitt "Ursache " müssen Sie die folgenden Schritte ausführen:
- Greifen Sie als Benutzer mit der Sicherheitsrolle "Systemadministrator" oder "System Customizer" auf die Dynamics 365-Webanwendung zu.
- Navigieren Sie zu Einstellungen, Anpassungen und Designs.
- Öffnen Sie das Design, das die Bildwebressource als Logo verwendet.
- Verwenden Sie das Logo-Nachschlagefeld, um den Verweis auf die Bildwebressource zu entfernen, die Teil der Lösung ist, die Sie löschen und speichern möchten.
- Versuchen Sie erneut, die Lösung zu löschen.