Die Suche filtert Datensätze für eine bestimmte Entität in Dynamics 365 nicht wie erwartet.

Dieser Artikel enthält Problemumgehungen für ein Problem, bei dem bei der Suche alle Datensätze statt nur die Datensätze angezeigt werden, die sich auf das, was Sie eingegeben haben, beziehen.

Gilt für: Power Apps
Ursprüngliche KB-Nummer: 4603850

Symptome

Wenn Sie in ein Nachschlagesteuerelement eingeben, werden bei der Suche alle Datensätze in der Ansicht angezeigt, nicht nur die Datensätze, die sich auf die Eingegebenen beziehen. Wenn Sie durch die Datensätze scrollen, sehen Sie, wie normal fett formatierter Datensatztext, wenn der Text mit dem Suchtext übereinstimmt.

Screenshot: Datensatztext fett formatiert wie normal, wenn der Text mit dem Suchtext übereinstimmt.

Ursache

Es gibt zwei mögliche Ursachen für dieses Problem:

Ursache 1

Das Problem tritt auf, weil keine "Find"-Spalten in der Schnellsucheansicht der Entität vorhanden sind.

Die Nachschlageansicht bestimmt, welche Spalten innerhalb des Nachschlagesteuerelements angezeigt werden, aber dieSuchspalten der Schnellsuche bestimmen - , welche Spalten im Nachschlagesteuerelement durchsucht werden. Wenn Sie einen Wert in ein Nachschlagesteuerelement eingeben, sucht es im Grunde nach einer Übereinstimmung innerhalb der Suchspalten. Anschließend werden Datensätze mit einer Übereinstimmung ausgewählt und Informationen angezeigt, die von der Lookup-Ansicht für Sie bestimmt werden. Der Grund, warum alle Datensätze angezeigt werden, ist, dass in der Schnellsucheansicht keine "Find"-Spalten festgelegt sind.

Hinweis

Die Spalten der Schnellsucheansicht sind nicht identisch mit DenSuchspalten der Schnellsucheansicht - . Es kann viele Spalten in der Schnellsucheansicht geben, aber wenn keine als "Suchen"-Spalten gekennzeichnet sind, funktioniert die Suche nicht wie erwartet.

Der Grund, warum die angezeigten und durchsuchten Spalten unterschiedlich sein können, ist ihre Leistung. Je weniger Spalten durchsucht werden, desto schneller kann die Suche ausgeführt werden. Möglicherweise möchten Sie jedoch viele Informationen im Nachschlagesteuerelement anzeigen, um sicherzustellen, dass Sie den richtigen Datensatz auswählen.

Die Schritte zum Hinzufügen von "Find"-Spalten finden Sie unter Problemumgehung 1.

Ursache 2

Das Problem tritt auf, weil es keine Zeichenfolgentypspalten in der Ansicht gibt, die vom Nachschlagesteuerelement verwendet wird.

Das Nachschlagesteuerelement kann keine Spalten vom Typ "Zeichenfolge" filtern. Die verwendete Ansicht muss mindestens eine Zeichenfolgenspalte aufweisen, z. B. Text, E-Mail, Telefon, URL usw.

Die Schritte zum Hinzufügen einer Zeichenfolgentypspalte finden Sie unter Problemumgehung 2.

Problemumgehungen

Verwenden Sie eine der folgenden Problemumgehungen, um dieses Problem zu umgehen:

Problemumgehung 1

  1. Wechseln Sie unter Anpassungen zur Schnellsucheansicht für die Entität des Nachschlagesteuerelements.

  2. Wählen Sie Suchspalten hinzufügen aus.

    Screenshot: Auswählen des Elements

  3. Fügen Sie alle Spalten hinzu, die innerhalb des Nachschlagesteuerelements durchsucht und abgeglichen werden sollen.

    Screenshot: Hinzufügen von Spalten, die innerhalb des Nachschlagesteuerelements durchsucht und abgeglichen werden sollen

  4. Speichern und veröffentlichen Sie Änderungen.

Problemumgehung 2

Sie müssen der ansicht, die vom Nachschlagesteuerelement verwendet wird, eine Zeichenfolgentypspalte hinzufügen.

  1. Wechseln Sie unter Anpassungen zu der Ansicht, die vom Nachschlagesteuerelement verwendet wird, in der die Filterung unterbrochen wird.

  2. Wählen Sie Spalten hinzufügen aus.

    Screenshot: Auswählen des Elements

  3. Fügen Sie mindestens eine Zeichenfolgentypspalte hinzu.