VM-Gast kann in Data Protection Manager nicht geändert oder aus einer Schutzgruppe entfernt werden

Dieser Artikel bietet eine Lösung für einen Fehler, der auftritt, wenn Sie eine Schutzgruppe ändern oder eine VM aus einer Schutzgruppe entfernen.

Ursprüngliche Produktversion: System Center 2016 Data Protection Manager
Ursprüngliche KB-Nummer: 4018988

Symptome

Wenn Sie versuchen, eine Schutzgruppe zu ändern, die Gäste des virtuellen Hyper-V-Computers (VM) enthält, oder wenn Sie versuchen, eine VM aus einer Schutzgruppe zu entfernen, erhalten Sie eine Fehlermeldung, die der folgenden ähnelt:

Fehler beim Entfernen Guest_Name:
Fehler 157: Guest_Name kann dem Schutz nicht hinzugefügt werden, da er bereits Mitglied einer Schutzgruppe ist.

Ursache

Dieses Problem ist auf doppelte Einträge in der DPM-Datenbank zurückzuführen. Die doppelten Einträge können auftreten, nachdem ein geschützter virtueller Computer von einem Hyper-V-Cluster zu einem anderen Hyper-V-Cluster migriert wurde und dieser virtuelle Computer dann im neuen Cluster erneut geschützt wird.

Fehlerbehebung

Um dieses Problem zu beheben, wenden Sie sich an Microsoft-Support, um Hilfe beim Entfernen der doppelten Einträge zu erfahren. Um zukünftige Vorkommen zu verhindern, aktivieren Sie die Livemigration. Informationen hierzu finden Sie unter Einrichten des Schutzes für die Livemigration.