Übersicht: IntelliCode für Visual Studio

IntelliCode für Visual Studio stellt die folgenden Funktionen bereit:

  • KI-gestütztes IntelliSense-Feature für mehrere Programmiersprachen, das nicht einfach eine alphabetische Liste der Member anzeigt, sondern die API vorhersagt, die ein Entwickler am wahrscheinlichsten benutzen möchte. Sie verwendet den aktuellen Codekontext und Muster des Entwicklers, um diese dynamische Liste bereitzustellen.

    Für C#-Benutzer stellt IntelliCode zusätzlich zu Membervorschlägen auch eine Argumentvervollständigung bereit. Mit dieser Funktion werden die am wahrscheinlichsten verwendeten Argumentnamen beim Aufruf einer Methode mit einem Stern versehen und am Anfang der Vervollständigungsliste angezeigt. Die Vervollständigungsliste wird angezeigt, sobald Sie innerhalb von Klammern mit dem Tippen beginnen oder STRG+LEERTASTE drücken.

    Argument completion in IntelliCode for Visual Studio

    C#-Entwickler in Visual Studio 2022 und höher profitieren auch von Vervollständigungen ganzer Zeilen, die basierend auf Ihrem bisherigen Code den nächsten Codeblock vorhersagen und als Inlinevorschlag anzeigen.

    C# Whole line completions in Visual Studio

  • KI-gestützte IntelliSense-Empfehlungen auf der Grundlage Ihres Codes (nur für C#).

  • Rückschlüsse auf den Codestil und auf Formatierungskonventionen zur dynamischen Erstellung einer EDITORCONFIG-Datei aus Ihrer eigenen Codebasis (nur für C#).

  • Vorschläge: IntelliCode verfolgt Ihre Bearbeitungen lokal nach, erkennt, wenn Sie eine wiederkehrende Aufgabe ausführen, und bietet Ihnen an, die gleiche Aktion an anderen, ähnlichen Stellen anzuwenden (nur C#).

    Suggestions for C# in Visual Studio

Previewfunktionen

Einige IntelliCode-Features sind Vorschaufeatures. Es kann daher nicht garantiert werden, dass diese zukünftig unterstützt werden. Previewfunktionen sind standardmäßig deaktiviert. Klicken Sie auf Extras>Optionen>IntelliCode, um IntelliCode-Vorschaufeatures zu aktivieren oder zu deaktivieren. Klicken Sie unter Vorschaufeatures auf Aktivieren, Deaktivieren, oder Standard, um die jeweiligen Features zu konfigurieren.

Unterstützte Sprachen

Folgende Programmiersprachen werden für KI-gestützte IntelliSense-Vervollständigungen unterstützt:

  • C#
  • XAML
  • C++
  • JavaScript und TypeScript
  • Visual Basic

Wie richte ich IntelliCode ein?

Ab Visual Studio 2019, Version 16.4, ist IntelliCode als integriertes Feature verfügbar, wenn Sie eine unterstützte Workload installieren.

Wenn Sie sich für bestimmte Programmiersprachen KI-gestützte IntelliSense-Vorschläge anzeigen lassen möchten, benötigen Sie möglicherweise eine neuere Version:

  • JavaScript und TypeScript erfordern TypeScript 3.4.2 oder höher.

Unterstützte Workloads

IntelliCode ist in Visual Studio 2019, Version 16.4, als Teil der folgenden Workloads enthalten:

  • Azure-Entwicklung
  • .NET-Desktopentwicklung
  • Mobile Entwicklung mit .NET
  • Spieleentwicklung mit Unity
  • Plattformübergreifende .NET Core-Entwicklung
  • ASP.NET und Webentwicklung
  • Entwicklung von Visual Studio-Erweiterungen
  • Entwicklung für die universelle Windows-Plattform
  • Office/SharePoint-Entwicklung
  • Desktopentwicklung mit C++
  • Spieleentwicklung mit C++
  • Mobile Entwicklung mit C++
  • Linux-Entwicklung mit C++

Problembehandlung

Wenn keine IntelliCode-Vorschläge angezeigt werden, sind unter Umständen Erweiterungen installiert, die die Anzeige der IntelliSense-Benutzeroberfläche verhindern. Dadurch werden mit einem Stern versehene IntelliCode-Vorschläge möglicherweise nicht ganz oben in der Liste angezeigt. Sie können überprüfen, ob Erweiterungen dieses Verhalten verursachen, indem Sie sie deaktivieren und IntelliSense erneut öffnen. Wenn die Erweiterung das Verhalten unterstützt, könne Sie die Features zur automatischen Vervollständigung deaktivieren.

Wenn Ihr Problem dadurch nicht behoben wird, melden Sie es über das Visual Studio-Feature Ein Problem melden, und merken Sie in Ihrem Bericht die Nutzung von IntelliCode an.

Telemetrie

IntelliCode erfasst einige anonymisierte Daten zur Nutzung und Fehlerberichtserstattung, um das Produkt zu verbessern. Es wird kein benutzerdefinierter Code an Microsoft gesendet, jedoch werden Informationen zur Verwendung der IntelliCode-Ergebnisse gesammelt.

Für Vorschläge des Basismodells, die auf Open-Source-Code oder .NET-Typen und -Membern basieren, wird erfasst, ob Sie einen IntelliCode-Vorschlag ausgewählt haben. Außerdem wird der Name dieses Vorschlags protokolliert. Microsoft verwendet diese Daten, um die Qualität des Basismodells zu überwachen. Für benutzerdefinierte Modelle wird erfasst, ob Sie IntelliCode-Vorschläge auswählen. Die Namen Ihrer benutzerdefinierten Typen oder Methoden werden hingegen nicht protokolliert.

Wenn Sie die Datensammlung deaktivieren möchten, müssen Sie der Teilnahme am Programm zur Verbesserung der Benutzerfreundlichkeit von Visual Studio widersprechen. Klicken Sie dazu in der Menüleiste auf Hilfe>Feedback senden>Einstellungen. Wählen Sie im Dialogfeld Programm zur Verbesserung der Benutzerfreundlichkeit von Visual StudioNein, ich möchte nicht teilnehmen aus, und klicken Sie dann auf OK.

Wenn Sie Modelle erstellen möchten, die Muster aus Ihrem C#-Code ableiten, müssen Sie sich bei Visual Studio anmelden. Erst danach können Sie den Trainingsdienst für Modelle verwenden. Dieser erfasst nur so viele Daten, wie notwendig sind, um das Modell zu erstellen. Microsoft sichert die trainierten Modelle so ab, dass diese nur für Ihr Konto und für Personen bereitstehen, für die Sie die Modelle freigeben. Das Modell und die Rückschlüsse aus Ihrem Code stehen nur Ihnen zur Verfügung. Weitere Informationen finden Sie unter Data and privacy (Datenschutz).

Feedback geben

Über das Menü Hilfe > Feedback senden > Ein Problem melden können Sie einen Fehler in IntelliCode für Visual Studio melden. Wenn Sie das Problem reproduzieren, bevor Sie den Bericht übermitteln, werden die Protokolle automatisch in diesen integriert.

Wenn Sie Featurevorschläge einreichen möchten, können Sie unten auf dieser Seite die Schaltfläche Feedback senden zu>Dieses Produkt auswählen, um ein neues Issue zu erstellen. Erwähnen Sie dabei, dass es sich um einen Vorschlag für ein Feature handelt.

Siehe auch