Szenario: Apache Tez-Anwendung reagiert in Azure HDInsight nicht mehr
In diesem Artikel werden Schritte zur Problembehandlung und mögliche Lösungen für Probleme bei der Interaktion mit Azure HDInsight-Clustern beschrieben.
Problem
Nach dem Übermitteln eines Apache Hive-Auftrags wird in der Tez-Ansicht der Auftragsstatus Wird ausgeführt angezeigt, es scheint jedoch keinen Fortschritt zu geben.
Ursache
Es wurden zu viele Aufträge übermittelt, die Yarn-Warteschlange ist lang.
Lösung
Skalieren Sie den Cluster zentral hoch, oder warten Sie, bis die Yarn-Warteschlange abgenommen hat.
Standardmäßig steuert yarn.scheduler.capacity.maximum-applications
die maximale Anzahl der ausgeführten und ausstehenden Anwendungen. Der Standardwert ist 10000
.
Nächste Schritte
Wenn Ihr Problem nicht aufgeführt ist oder Sie es nicht lösen können, besuchen Sie einen der folgenden Kanäle, um weitere Unterstützung zu erhalten:
Nutzen Sie den Azure-Communitysupport, um Antworten von Azure-Experten zu erhalten.
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