ArchiveStatus ist für ein aktives Archivpostfach in Microsoft 365 auf "Keine" festgelegt.

Ursprüngliche KB-Nummer: 4486848

Problembeschreibung

Microsoft 365 Online-Archive ermöglichen zusätzlichen Speicher der E-Mail-Nachrichten von Benutzern. In einigen Szenarien ist die ArchiveStatus-Eigenschaft jedoch möglicherweise auf "None" festgelegt, obwohl Sie ein aktives Archiv für das Postfach eines Benutzers in Microsoft 365 aktiviert haben.

Wenn Sie beispielsweise das folgende Cmdlet in Exchange Online PowerShell ausführen, um den Archivstatus zu überprüfen, wird der Status als "Keine" anstelle von "Aktiv" angezeigt:

Get-mailbox id|fl ArchiveStatus

Die Ausgabe des Cmdlets sieht wie folgt aus:

ArchiveStatus: None

Hinweis

Obwohl ArchiveStatus "None" anzeigt, kann der Benutzer auf das Onlinearchiv zugreifen, und gültige ArchiveGuid - und ArchiveDatabase-Eigenschaften werden festgelegt.

Ursache

Eines der folgenden Szenarien kann dazu führen, dass " ArchiveStatus " als "Keine" angezeigt wird.

  • Ein Benutzer wird für ein Archivpostfach erneut lizenziert.
  • Verschieben eines primären und Archivpostfachs von lokal nach Microsoft 365.

Lösung

Sie sollten den Wert der ArchiveStatus-Eigenschaft nicht verwenden, um den Status des Archivs zu überprüfen, es sei denn, dies ist ein lokales Szenario, in dem das primäre Postfach lokal ist und das Archivpostfach in Microsoft 365 vorhanden ist (d. a. das lokale Archiv). In allen anderen Szenarien sollten Sie die beiden folgenden Eigenschaften verwenden, um den Status des Archivs zu bestätigen:

  • ArchiveDatabase
  • ArchiveGuid

Führen Sie beispielsweise das folgende Cmdlet aus:

Get-mailboxUserName|fl archivedatabase,archiveguid

Die Ausgabe sollte etwa wie folgt aussehen:

ArchiveDatabase :DatabaseIdParameterArchiveGuid :GUID