Archivpostfach kann nach der Migration eines Postfachs zu Office 365 Dedicated/ITAR vNext nicht bereitgestellt oder aufgehoben werden.

Ursprüngliche KB-Nummer: 4009935

Symptom

Nachdem ein Postfach, das nicht über ein Archiv verfügt, zu Microsoft Office 365 Dedicated/ITAR vNext migriert wurde, können Sie dem Postfach kein Archiv hinzufügen. Sie können auch kein Archiv aus einem Postfach aufheben, das von Dedicated migriert wurde.

Wenn Sie versuchen, ein Archiv über das Exchange Admin Center oder Remote PowerShell enable-mailboxbereitzustellen, erhalten Sie die folgende Fehlermeldung:

Der folgende Fehler ist während der Überprüfung im Agent "Windows LiveId Agent" aufgetreten: "Das Archiv für "John" kann nicht aktiviert werden, da dieses Benutzerobjekt mit dem lokalen Verzeichnis synchronisiert wird. Um ein cloudbasiertes Archivpostfach für diesen Benutzer zu aktivieren, müssen Sie Das lokale Exchange Admin Center oder die Exchange-Verwaltungsshell verwenden.

Ursache

Wenn Exchange Online in einer Hybridtopologie bereitgestellt wird, erwartet das System, dass alle Verwaltungen über eine lokale Exchange-Installation ausgeführt werden. Dadurch kann das lokale Verzeichnis und das Onlineverzeichnis synchronisiert bleiben.

Viele dedizierte Benutzer haben exchange Server nicht lokal installiert. Die Migration von Dedicated bewirkt jedoch, dass die Objekte als Teil einer Hybridbereitstellung funktionieren. Obwohl die Lokale Bereitstellung von Exchange für die Verwaltung empfohlen wird, um eine einfachere Migration zu erleichtern und die Gesamtkosten zu senken, ist die Installation von Exchange lokal für den vNext-Übergang nicht erforderlich. Daher können einige Kunden möglicherweise keine Archive für Postfächer verwalten, die von Dedicated migriert wurden.

Hinweis

Dies gilt nicht für Benutzer, die direkt in vNext bereitgestellt werden.

Lösung

Nach einer Migration können Die Verwaltung von Archiven für Postfächer, die von Dedicated migriert wurden, mit Skripts ausgeführt werden, die die Funktionalität einer lokalen Exchange-Bereitstellung emulieren.

Voraussetzungen

  • Das Active Directory-Modul für Windows PowerShell muss auf dem Verwaltungscomputer installiert sein.
  • Auf dem Verwaltungscomputer muss .NET 4.0 oder eine höhere Version installiert sein.
  • Der Verwaltungscomputer muss mit der lokalen AD-Gesamtstruktur der Benutzer verbunden sein, die verwaltet werden.
  • Der Betreiber muss über Kontobetreiberberechtigungen oder gleichwertige Rechte verfügen.
  • Die Skripts enable-remotearchive.ps1 und disable-remotearchive.ps1 müssen sich auf dem Verwaltungscomputer befinden.

Bereitstellen eines Archivs

  1. Ermitteln Sie den Wert für die Eigenschaft "name" des verwalteten Benutzers. Dieser Schritt wird als Wert für den Parameter "-Identity" des Skripts übergeben.

  2. Starten Sie PowerShell mit aktivierter Active Directory-Modul für Windows PowerShell.

  3. Führen Sie folgendes Skript aus:

    Enable-remotearchive.ps1 -Identity 'John'

  4. Warten Sie, bis Microsoft Entra Connect die Änderungen synchronisiert. Optional: Der Parameter "ArchiveName " gibt den Namen des Archivpostfachs an. Dies ist der Name, der Benutzern in Outlook und Outlook Web App (OWA) angezeigt wird. Wenn Sie diesen Parameter nicht verwenden, ist der Standardwert "In-Place Archive" – <Mailbox_User_Display_Name>.

Aufheben der Bereitstellung eines Archivs

  1. Ermitteln Sie den Wert für die Eigenschaft "name" des verwalteten Benutzers. Dieser Schritt wird als Wert für den Parameter "-Identity" des Skripts übergeben.

  2. Starten Sie PowerShell mit aktivierter Active Directory-Modul für Windows PowerShell.

  3. Führen Sie folgendes Skript aus:

    disable-remotearchive.ps1 -Identity 'John'

  4. Warten Sie, bis Microsoft Entra Connect die Änderungen synchronisiert.