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Die Option Zulassen, dass Email Router meine Anmeldeinformationen verwendet, ist in Microsoft Dynamics CRM 2011 nicht verfügbar.

Dieser Artikel bietet eine Lösung für das Problem, dass die Option Zulassen, dass Email Router meine Anmeldeinformationen verwendet, um E-Mails in meinem Namen zu senden und zu empfangen, in Microsoft Dynamics CRM Persönliche Optionen nicht verfügbar ist.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 2667140

Problembeschreibung

Die Option Zulassen, dass Email Router meine Anmeldeinformationen verwendet, um E-Mails in meinem Namen zu senden und zu empfangen, ist in Microsoft Dynamics CRM persönlichen Optionen ausgegraut.

Ursache

Bei der Verarbeitung von E-Mails für einen Benutzer oder eine Warteschlange benötigt der E-Mail-Router Anmeldeinformationen für den Benutzer oder die Warteschlange. Diese Anmeldeinformationen können in der Microsoft Dynamics CRM-Webanwendung im Dialogfeld Persönliche Optionen festlegen (für Benutzer) und im Formular Warteschlangen (für Warteschlangen) eingegeben werden. Microsoft Dynamics CRM speichert diese Anmeldeinformationen verschlüsselt in der Microsoft Dynamics CRM-Datenbank. Der E-Mail-Router verwendet einen Schlüssel, der in der Microsoft Dynamics CRM-Datenbank gespeichert ist, um diese Anmeldeinformationen zu entschlüsseln. Der Aufruf, den der E-Mail-Router zum Abrufen dieses Schlüssels vornimmt, erzwingt HTTPS. In Microsoft Dynamics CRM 2011 funktioniert der E-Mail-Router standardmäßig so, was bedeutet, dass Sie keine Maßnahmen ergreifen müssen, um dieses Verhalten beizubehalten.

Lösung

Führen Sie zum Beheben des obigen Problems die folgenden Schritte aus, um den Registrierungsschlüssel DisableSecureDecryptionKey auf dem Microsoft Dynamics CRM Server hinzuzufügen.

  1. Starten Sie den Registrierungs-Editor auf dem Microsoft Dynamics CRM Server, indem SieAusführenstarten> auswählen und regedit eingeben.

  2. Suchen Sie den folgenden Pfad auf dem Microsoft Dynamics CRM Server:

    HKEY_Local_Machine\Software\Microsoft\MSCRM

  3. Überprüfen Sie den Wert des Registrierungsschlüssels DisableSecureDecryptionKey. Wenn dieser Registrierungsschlüssel vorhanden ist, legen Sie seinen Wert auf 1 fest. (Wenn der Schlüssel nicht vorhanden oder auf 0 festgelegt ist, werden Aufrufe vom E-Mail-Router an den Microsoft Dynamics CRM Server 2011 über HTTPS durchgeführt.) Wenn Sie den Wert dieses Schlüssels auf 1 festlegen, kann der E-Mail-Router Informationen aus der Microsoft Dynamics CRM Datenbank über das HTTP-Protokoll abrufen.

  4. Wenn Sie den Wert von DisableSecureDecryptionKeygeändert haben, führen Sie auf der Microsoft Dynamics CRM Server 2011 die folgenden Schritte aus, um Internetinformationsdienste (IIS) neu zu starten. Um dasselbe auszuführen, wählen Sie Start>Run (Ausführung starten) aus, geben Sie cmd ein, und wählen Sie dann OK aus.

  5. Geben Sie IISRESET im Eingabeaufforderungsfenster ein。

  6. (Empfohlen) Aktivieren Sie IPSec für die gesamte Kommunikation zwischen dem Microsoft Dynamics CRM Server 2011 und dem E-Mail-Routercomputer. Weitere Informationen zum Aktivieren von IPSec finden Sie unter Was ist IPSec?.

Weitere Informationen

Wenn Ihr organization den E-Mail-Router verwendet, um Nachrichten im Namen von Benutzern oder Warteschlangen zu senden und zu empfangen, sollten Sie die Sicherheit erhöhen. Weitere Informationen finden Sie unter Schützen von Benutzeranmeldeinformationen.