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Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie einen neuen oder bearbeiten vorhandenen Workflow in Microsoft Dynamics 365 erstellen.
Gilt für: Microsoft Dynamics CRM
Ursprüngliche KB-Nummer: 4053915
Symptome
Beim Erstellen eines neuen oder Bearbeitens eines vorhandenen Workflows in Microsoft Dynamics 365 wird möglicherweise der Fehler angezeigt:
"Ein Element mit demselben Schlüssel wurde bereits hinzugefügt".
Wenn Sie die Schaltfläche "Protokoll herunterladen" auswählen, werden die folgenden Informationen angezeigt:
Unbehandelte Ausnahme: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: System.ArgumentException: Ein Element mit demselben Schlüssel wurde bereits hinzugefügt. Detail:
<OrganizationServiceFault xmlns:i="https://www.w3.org/2001/XMLSchema-instance
" xmlns="https://schemas.microsoft.com/xrm/2011/Contracts
">
<ActivityId>xxx</ActivityId>
<ErrorCode-2147220970></ErrorCode>
<ErrorDetails xmlns:d2p1="https://schemas.datacontract.org/2004/07/System.Collections.Generic
" />
<Message>System.ArgumentException: Ein Element mit demselben Schlüssel wurde bereits hinzugefügt.</Nachricht>
<Zeitstempel>2017-11-08T20:52:35.6280057Z</Zeitstempel>
<ExceptionRetriable>falsch</ExceptionRetriable>
<ExceptionSource i:nil="true" />
<InnerFault i:nil="true" />
<OriginalException i:nil="true" />
<TraceText i:nil="true" />
</Organisationsdienstfehler>
Wenn die Plattformablaufverfolgung aktiviert wurde, werden die folgenden Fehler in der Ablaufverfolgung protokolliert.
MSCRM-Fehlerbericht:
Fehler: Ein Element mit demselben Schlüssel wurde bereits hinzugefügt.
Fehlermeldung: Ein Element mit demselben Schlüssel wurde bereits hinzugefügt.
Quelldatei: Nicht verfügbar
Zeilennummer: Nicht verfügbar
Anforderungs-URL:https://CrmOrgName.dynamics.com/AppWebServices/Workflow.asmx
Stack Trace Info: [ArgumentException: Ein Element mit demselben Schlüssel wurde bereits hinzugefügt.]
bei System.ThrowHelper.ThrowArgumentException(ExceptionResource)
at System.Collections.Generic.Dictionary'2.Insert(TKey key, TValue value, Boolean add)
at Microsoft.Crm.Application.Components.UI.OptionGroup.AddItem(String text, String value, ListDictionary expandos)
bei Microsoft.Crm.Application.Controls.CreateStepControl.RenderEntityList(HtmlTextWriter writer, StepControlType stepType, String onChange)
at Microsoft.Crm.Application.Controls.StepBaseControl.RenderEntity(HtmlTextWriter writer, StepControlType stepType, String onChange)
bei Microsoft.Crm.Application.Controls.CreateStepControl.Render(HtmlTextWriter Writer)
at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter)
at Microsoft.Crm.Application.Controls.CompositeStepBaseControl.RenderChildSteps(HtmlTextWriter writer)
Bei Microsoft.Crm.Application.Controls.WorkflowStepControl.Render(HtmlTextWriter writer)
bei System.Web.UI.Control.RenderControlInternal(HtmlTextWriter Writer, ControlAdapter adapter)
at Microsoft.Crm.Application.WebServices.WorkflowWebService.RenderWorkflow(WorkflowStep workflowStep, Boolean bSave, String parentStepId, String rendererTypeCode)
bei Microsoft.Crm.Application.WebServices.WorkflowWebService.RenderWorkflow(WorkflowStep workflowStep, String parentStepId, String rendererTypeCode)
at Microsoft.Crm.Application.WebServices.WorkflowWebService.AddCreateEntityStep(String parentId, String entityId, String descriptionXml, String parentStepId, String rendererTypeCode)
Darüber hinaus wird möglicherweise auch die folgende Meldung angezeigt.
MSCRM:ASSERTEX - ENTITÄT Singular LOKALISIERTER NAME NICHT GEFUNDEN: logischer Name = 'msdyn_orginsightsuserdashboarddefinition' Sprache ID = 1033
Ursache
Eine mögliche Ursache für diesen Fehler ist eine Entitätsbenennungskonvention innerhalb von Anpassungen. Verweisen Sie für diesen bestimmten Fehler auf den Attributnamen, der im MSCRM:ASSERTEX
-Teil des Fehlers aufgeführt ist. Siehe unten:
MSCRM:ASSERTEX - ENTITY Singular lokalisierter Name nicht gefunden: logischer Name = 'msdyn_orginsightsuserdashboarddefinition' LANGUAGE ID = 1033
Das Problem bleibt bei der Entität, die das Attribut msdyn_orginsightsuserdashboarddefinition
enthält. Sie müssen in den Microsoft Dynamics 365-Anpassungen nach diesem Attribut suchen.
Die problematische Entität ist leicht in Anpassungen zu finden, da sie normalerweise oben in den Entitäten ohne Namen aufgeführt ist. Sehen Sie den folgenden Screenshot:
Lösung
Um diesen Fehler zu beheben, müssen Sie der Entität, die Sie im Bereich Ursache lokalisiert haben, einen Anzeigenamen sowie einen Pluralnamen zuweisen.
Öffnen Sie den Microsoft Dynamics 365-Webclient als D365-Administrator.
Wählen Sie dann "Einstellungen", dann "Anpassungen" und dann " System anpassen" aus.
Sobald sich das Anpassungsfenster öffnet, erweitern Sie Entitäten.
Wählen Sie die Entität oben aus, die keinen Anzeigenamen hat.
Weisen Sie im rechten Fensterbereich der Entität einen Anzeigenamen und einen Pluralnamen zu. Siehe Screenshot unten.
Wählen Sie nach dem Benennen der Entität "Speichern" und dann "Veröffentlichen" aus.
Kehren Sie schließlich zum Workflow-Editor zurück, und versuchen Sie, einen neuen Workflow zu erstellen oder einen vorhandenen Workflow zu bearbeiten. Es wird jetzt erfolgreich sein.