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Email Serverfehlercode Crm.80042f09.UserNotAssignedRoles nach Auswahl von Testen & Postfach für einen Postfachdatensatz aktivieren

Dieser Artikel enthält eine Lösung für den Fehlercode Crm.80042f09.UserNotAssignedRoles, der auftritt, nachdem Sie die Schaltfläche Test & Enable Mailbox (Postfach aktivieren) in einem Postfachdatensatz in Microsoft Dynamics 365 ausgewählt haben.

Gilt für: Microsoft Dynamics CRM
Ursprüngliche KB-Nummer: 4014646

Problembeschreibung

Wenn Sie in einem Postfachdatensatz in Microsoft Dynamics 365 die Schaltfläche & Postfach aktivieren auswählen, wird die folgende Warnung protokolliert, und die Synchronisierung von Terminen, Kontakten und Aufgaben schlägt fehl:

Termine, Kontakte und Aufgaben können für den Postfachnamen <> nicht synchronisiert werden, da der Postfachbenutzer nicht über ausreichende Berechtigungen für dieses Postfach verfügt.
Email Server-Fehlercode: Crm.80042f09.UserNotAssignedRoles

Wenn Sie die Details anzeigen möchten, werden die folgenden zusätzlichen Details angezeigt:

T:1738ActivityId: <ID Exception>>: Unhandled Exception: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: Failed to retrieve the sync state : Unhandled Exception: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: SecLib::RetrievePrivilegeForUser failed - dem Benutzer sind keine Rollen zugewiesen. Hr = -2147209463, Benutzer: <GUID> Detail: <ID> -2147209463 SecLib::RetrievePrivilegeForUser failed - dem Benutzer sind keine Rollen zugewiesen. Hr = -2147209463 zurückgegeben, Benutzer: <GUID>...

Ursache

Eine Microsoft Dynamics 365-Sicherheitsrolle ist dem Benutzer nicht zugewiesen.

Lösung

Weisen Sie dem Benutzer eine Microsoft Dynamics 365-Sicherheitsrolle zu. Schrittweise Anweisungen zum Zuweisen einer Sicherheitsrolle finden Sie unter Erstellen von Benutzern und Zuweisen von Sicherheitsrollen.