Langsame Leistung beim Anheften von Ansichten in Microsoft Dynamics CRM
Dieser Artikel hilft Ihnen, das Problem zu beheben, das auftritt, wenn Sie Ansichten in Microsoft Dynamics CRM Client für Microsoft Office Outlook anheften.
Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 2741514
Symptome
Microsoft Dynamics CRM-Client für Microsoft Office Outlook kann beim Anheften von Ansichten langsam ausgeführt werden.
Ursache
Wenn eine Ansicht angeheftet wird, werden die Datensätze in der Ansicht in die lokale SQL CE-Datenbank in der {orgid.sdf} abgerufen und zwischengespeichert. Wenn Ansichten angeheftet sind, werden sie einem Benutzer in der Listenansicht und nicht in seitenseitigen Ansichten angezeigt. Jedes Mal, wenn auf eine angeheftete Ansicht zugegriffen wird, gibt sie Ergebnisse aus den lokalen SDF-Dateien zurück.
Diese Daten werden regelmäßig als Hintergrundprozess aktualisiert. Wenn ein Benutzer über mehrere angeheftete Ansichten oder auf Computern verfügt, die nicht über viele Ressourcen verfügen, kann dies zu langsamen Leistungs- und Ladeproblemen führen.
Lösung
Um zu verhindern, dass angeheftete Ansichten Informationen in lokale SQL CE-Caches abrufen, kann ein Registrierungsschlüssel für die Microsoft Dynamics CRM 2011 Outlook-Clients festgelegt werden. Dies kann auch dazu beitragen, den gesamten Netzwerkdatenverkehr zu reduzieren, der von einem Microsoft Dynamics CRM 2011-Server an einen Microsoft Dynamics CRM 2011 Outlook-Clientcomputer gesendet wird.
Wenn dieser Wert auf 1 festgelegt ist, haben Benutzer weiterhin die Möglichkeit, die Ansichten anzuheften. Die Abfrage wird jedoch an den CRM-Server gesendet, um die Ergebnisse anstelle des lokalen Caches abzurufen.
Wichtig
Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher müssen Sie sicherstellen, dass Sie diese Schritte sorgfältig ausführen. Für weiteren Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie unter: Sichern und Wiederherstellen der Registrierung Windows.
Um dieses Problem zu beheben, führen Sie folgende Schritte aus:
- Melden Sie sich bei den Microsoft Dynamics CRM 2011 Outlook-Clientcomputern als Benutzer an, der den Microsoft Dynamics CRM 2011 Outlook-Client installiert hat.
- Klicken Sie auf Start und dann auf Ausführen. Geben Sie regedit& ein, und klicken Sie auf OK. Navigieren Sie zum Registrierungsschlüssel.
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Zeigen Sie im Menü "Bearbeiten " auf "Neu", und klicken Sie dann auf "DWORD"-Wert (32-Bit). - Geben Sie DisableMapiCaching ein, und drücken Sie dann die EINGABETASTE.
- Klicken Sie mit der rechten Maustaste auf "DisableMapiCaching", zeigen Sie auf "Neu", und klicken Sie dann auf "DWORD-Wert".
- Klicken Sie mit der rechten Maustaste auf "DisableMapiCaching", und klicken Sie dann auf " Ändern".
- Geben Sie in das Datenfeld Wert den Wert 1 ein, und klicken Sie dann auf OK.
- Beenden Sie den Registrierungs-Editor.
Weitere Informationen
Updaterollup 6 oder höher muss installiert werden, damit der DisableMapiCaching-Registrierungsschlüssel funktioniert. Weitere Informationen zum Updaterollup 6 finden Sie unter KB Microsoft Dynamics CRM 2011 UpdateRollup 6.
Notiz
Dieser Registrierungsschlüssel ist nach der Anwendung des Updaterollups 14 ungültig. Dies muss mithilfe des OrgDbOrgSettings-Tools aktualisiert werden.