Sie sind nicht berechtigt, diesen Seitenfehler anzuzeigen, wenn Sie versuchen, auf die Microsoft Dynamics CRM-Website zuzugreifen.
Dieser Artikel enthält eine Lösung für das Problem, das Sie möglicherweise erhalten, dass Sie nicht berechtigt sind, diesen Seitenfehler anzuzeigen, der auftritt, wenn Sie versuchen, auf die Microsoft Dynamics CRM-Website zuzugreifen.
Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 917818
Symptome
Wenn Sie versuchen, auf die Microsoft Dynamics CRM-Website zuzugreifen, werden Sie dreimal zur Eingabe von Domänenanmeldeinformationen aufgefordert. Anschließend erhalten Sie die folgende Fehlermeldung:
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HTTP-Fehler 401.1 – Nicht autorisiert: Der Zugriff wird aufgrund ungültiger Anmeldeinformationen verweigert.
Ursache
Dieses Problem kann auftreten, wenn eine der folgenden Bedingungen zutrifft:
- Die Microsoft-Internetinformationsdienste(IIS)-Authentifizierung für die Microsoft Dynamics CRM-Website ist nicht für die Verwendung der Kerberos-Authentifizierung konfiguriert.
- Die Microsoft Dynamics CRM-Website ist für die Verwendung von Hostheadern konfiguriert.
Lösung
Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
Ermitteln des Bezeichners, den die Microsoft Dynamics CRM-Website verwendet
Wählen Sie auf dem Microsoft Dynamics CRM-Server "Start", dann "Verwaltungstools" und dann Internetinformationsdienste (IIS)-Manager aus.
Erweitern Sie den Namen des Microsoft Dynamics CRM-Computers, und wählen Sie dann "Websites" aus.
Wählen Sie die Microsoft Dynamics CRM-Website aus, und notieren Sie sich dann den Wert in der Spalte "Bezeichner ".
Notiz
Wenn Sie Microsoft Dynamics CRM auf der Standardwebsite installiert haben, ist dieser Wert 1.
Überprüfen Sie den Microsoft Dynamics CRM-Websitebezeichner. Gehen Sie dazu wie folgt vor:
Wählen Sie Start und dann Ausführen aus, geben Sie regedit ein, und wählen Sie anschließend OK aus.
Suchen Sie den folgenden Registrierungsunterschlüssel:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
Wählen Sie "Website" aus, und notieren Sie den Wert im Feld "Wert".
Notiz
Der Wert ähnelt /LM/W3SVC/1. Die letzte Zahl sollte mit dem Websitebezeichner identisch sein, den Sie in Schritt 3 angegeben haben.
Konfigurieren von IIS für die Verwendung der Kerberos-Authentifizierung für die Microsoft Dynamics CRM-Website
Wählen Sie "Start" aus, wählen Sie "Ausführen" aus, geben Sie cmd ein, und wählen Sie dann "OK" aus.
Geben Sie an der Eingabeaufforderung den folgenden Befehl ein und drücken Sie dann die EINGABETASTE:
C:\Inetpub\AdminScripts\adsutil.vbs get w3svc/1/NTAuthenticationProviders
Notiz
In diesem Befehl stellt 1 den Wert dar, den Sie im Abschnitt "Bestimmen des Bezeichners bestimmen" festgelegt haben, den die Microsoft Dynamics CRM-Website verwendet.
Das Ergebnis gibt an, dass die Authentifizierung nicht auf dieser Ebene festgelegt ist oder dass die Authentifizierung auf NTAuthenticationProviders: (STRING)"NTLM" festgelegt ist. Daher müssen Sie die Kerberos-Authentifizierung festlegen.
Geben Sie an der Eingabeaufforderung den folgenden Befehl ein und drücken Sie dann die EINGABETASTE:
C:\Inetpub\AdminScripts\adsutil.vbs set w3svc/1/NTAuthenticationProviders "Negotiate,NTLM"
Notiz
In diesem Befehl stellt 1 den Wert dar, den Sie im Abschnitt "Bestimmen des Bezeichners bestimmen" festgelegt haben, den die Microsoft Dynamics CRM-Website verwendet.
Um zu überprüfen, ob die Kerberos-Authentifizierung ordnungsgemäß festgelegt ist, geben Sie den folgenden Befehl an der Eingabeaufforderung ein, und drücken Sie dann die EINGABETASTE:
C:\Inetpub\AdminScripts\adsutil.vbs get w3svc/1/NTAuthenticationProviders
Notiz
In diesem Befehl stellt 1 den Wert dar, den Sie im Abschnitt "Bestimmen des Bezeichners bestimmen" festgelegt haben, den die Microsoft Dynamics CRM-Website verwendet.
Daraus ergibt sich folgendes Ergebnis:
NTAuthenticationProviders: (STRING)"Negotiate,NTLM"
Starten Sie den Microsoft Dynamics CRM-Server neu.
Notiz
Sie können einen Hostheader verwenden, um auf die Microsoft Dynamics CRM-Website zuzugreifen. Wenn Sie dies tun, müssen Sie auch die Anweisungen in diesem Artikel befolgen, um das Problem zu beheben.