Fehler bei GetReportOptions im Berichtsplaner in Microsoft Business Solutions – Business Portal zusammen mit Microsoft Dynamics SL
Dieser Artikel bietet eine Lösung für einen Fehler, der auftritt, wenn Sie den Berichtsplaner in Microsoft Business Solutions – Business Portal zusammen mit Microsoft Dynamics SL eingeben.
Gilt für: Microsoft Dynamics SL
Ursprüngliche KB-Nummer: 912091
Problembeschreibung
Wenn Sie berichtsplaner in Microsoft Business Solutions - Business Portal zusammen mit Microsoft Dynamics SL eingeben, erhalten Sie möglicherweise die folgende Fehlermeldung:
Fehler bei GetReportOptions. Error info= <soap:Server : System.Web.Services.Protocols.SoapExcpetion: Server konnte die Anforderung nicht verarbeiten. >--- System.NullReferenceExcpetion: Der Objektverweis ist nicht auf eine instance eines Objekts festgelegt.
Ursache
Der Microsoft Solomon-Client ist nicht auf dem Server installiert, auf dem das Business Portal ausgeführt wird.
Lösung
Führen Sie die folgenden Schritte aus, um den Microsoft Solomon-Client auf dem Server zu installieren, auf dem das Business Portal ausgeführt wird:
Ordnen Sie dem Server, auf dem Microsoft Solomon ausgeführt wird, ein Laufwerk zu:
Wählen Sie in Windows Explorer im Menü Extras die Option Netzlaufwerk zuordnen aus.
Wählen Sie in der Liste Laufwerk einen Laufwerkbuchstaben aus.
Geben Sie im Feld Ordner den Pfad für den Ordner Solomon auf dem Server ein, auf dem Microsoft Solomon ausgeführt wird.
Hinweis
Standardmäßig befindet sich der Ordner Solomon unter
\\SolomonServerName\ProgramFiles\Solomon
. In diesem Beispiel steht SolomonServerName für den Namen des Servers, auf dem Microsoft Solomon ausgeführt wird.
Öffnen Sie im Ordner Solomon den Ordner Wrkstn.
Führen Sie die Setup.exe-Datei aus, die sich im Ordner Wrkstn befindet.