Hinweis
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, sich anzumelden oder das Verzeichnis zu wechseln.
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, das Verzeichnis zu wechseln.
Dieser Artikel enthält eine Lösung für ein Problem, bei dem die pausedon Eigenschaft einer SLA-KPI-Instanz (Service Level Agreements) auf NULL festgelegt ist, wenn der Status der SLA-Instanz im Haltemodus (angehalten) ist.
Problembeschreibung
Wenn Sie einen Fall aktualisieren, erhalten Sie die folgende Fehlermeldung:
Ausnahmemeldung: Ausnahme in benutzerdefinierter SLAInstance-Verwaltungsaktion : System.InvalidOperationException: Nullable-Objekt muss einen Wert aufweisen.
Ursache
Die pausedon Eigenschaft der SLA-KPI-Instanz wird über eine benutzerdefinierte Logik oder einen Workflow auf NULL aktualisiert, wenn der Status der SLA-KPI-Instanz im Haltezustand (angehalten) ist. Daher wird der Wert des pausedon Werts nicht aufgefüllt.
Lösung
Um dieses Problem zu beheben, überprüfen Sie, ob benutzerdefinierte Logik oder Workflow für den STATUSübergang der SLA-KPI-Instanz implementiert ist.
Wenn eine benutzerdefinierte Logik oder ein Workflow implementiert wird, um den Status der SLA-KPI-Instanz zu aktualisieren, deaktivieren Sie die benutzerdefinierte Logik oder den Workflow, und verwenden Sie die sofort einsatzbereite Funktionalität, um den STATUS der SLA-KPI-Instanz anzuhalten und fortzusetzen.