"Dateneingabefehler in Batch RMPMXFR UserID" Fehlermeldung beim Auswählen von "Prozess" im Fenster "Erstattungsüberprüfungen erstellen" in Microsoft Dynamics GP
Dieser Artikel bietet eine Lösung für einen Fehler, der auftritt, wenn Sie in Microsoft Dynamics GP im Fenster Erstattungsprüfungen erstellen die Option Verarbeiten auswählen.
Gilt für: Microsoft Dynamics GP
Ursprüngliche KB-Nummer: 933027
Wichtig
Bevor Sie die Anweisungen in diesem Artikel befolgen, stellen Sie sicher, dass Sie über eine vollständige Sicherungskopie der Datenbank verfügen, die Sie wiederherstellen können, wenn ein Problem auftritt.
Symptome
Wenn Sie im Fenster Erstattungsprüfungen erstellen die Option Prozess und dann Übertragen auswählen, treten möglicherweise die folgenden Probleme auf.
Szenario 1
Die folgende Fehlermeldung wird angezeigt:
Dateneingabefehler in batch RMPMXFR UserID. Verwenden Sie das Fenster Batch Recovery, um diesen Batch zu verarbeiten.
Hinweis
UserID ist ein Platzhalter für den Anmeldenamen des Benutzers, der die Rückerstattungsprüfungen verarbeitet. Dieser Anmeldename ist Teil des Batchnamens.
Wenn das Kontrollkästchen Kreditorenprüfungen automatisch öffnen im Fenster "Rückerstattungsprüfungen einrichten" aktiviert ist, wird diese Fehlermeldung angezeigt, bevor das Fenster "Kreditorenprüfung drucken" angezeigt wird.
Sie wählen OK aus, nachdem Sie die Fehlermeldung erhalten haben. Wenn Sie den Überprüfungsbatch weiterhin drucken, erhalten Sie die folgende Fehlermeldung:
In diesem Überprüfungsbatch wurden Fehler gefunden. Korrigieren Sie die Fehler vor dem Drucken.
Hinweis
Wenn Sie die mehrdimensionale Analyse (Multi-Dimensional Analysis, MDA) für eines der gl-Konten aktiviert haben, die in der Rückerstattungsprüfung verwendet werden, und wenn eine MDA-Analysegruppe auf Erforderlich festgelegt ist, aber keine Standard-MDA-Code-IDs definiert sind, tritt der gleiche Fehler auf, und es wird auch ein leerer Datensatz in der PM20000 Tabelle erstellt. Danach muss der beschädigte Datensatz manuell aus der PM20000 Tabelle entfernt werden. Das Problem kann vermieden werden, indem Entweder eine standardmäßige MDA-Analysecode-ID für das MDA-Konto/die MDA-Analysegruppe auf 100 % festgelegt ist, oder indem Sie die zugewiesene MDA-Analysegruppen-ID für das Konto auf Optional anstelle von Erforderlich festlegen.
Szenario 2
- Sie zeigen die Kreditorentransaktionen im Fenster "Kreditorentransaktionsanfrage – Kreditor" an.
- Sie wählen die Zeile für den Anbieter aus.
- Sie drücken die TAB-TASTE, um aus einem Feld zu wechseln.
In diesem Szenario wird die folgende Fehlermeldung angezeigt:
Die gespeicherte Prozedur createSQLTmpTable hat die folgenden Ergebnisse zurückgegeben: DBMS 2627, Microsoft Dynamics GP:0.
Das Fenster "Kreditorentransaktionsanfrage – Kreditor" enthält die folgenden zwei Arbeitsdokumente, die sich aus der Bearbeitung der Rückerstattungsprüfung ergeben haben:
- Die Scheckzahlung für die Rückerstattung
- Eine sonstige Gebühr
Hinweis
Im Fenster "Kreditorentransaktionsanfrage – Kreditor" werden keine doppelten Dokumente angezeigt.
Wenn Sie das Kontrollkästchen Arbeit und das Kontrollkästchen Verlauf deaktivieren und dann Erneut anzeigen auswählen, wird ein anderes Dokument für verschiedene Gebühren angezeigt. Dieses Dokument weist den status Open auf, und die doppelte Fehlermeldung wird nicht angezeigt. Wenn Sie einen Drilldown für dieses geöffnete Dokument ausführen, fallen für die sonstigen Gebühren keine Beträge an, und es scheint beschädigt zu sein. Dieses Dokument wird nicht angezeigt, wenn Sie die folgenden Kontrollkästchen gleichzeitig aktivieren:
- Work
- Open
- Verlauf
Ursache
Ursache des Szenarios 1
Dieses Problem tritt auf, wenn die Buchung der sonstigen Gebühren in der Kreditorenverwaltung in Microsoft Dynamics GP aus einem der folgenden Gründe unterbrochen wird:
- Das Kreditorenkonto wird im Fenster Kreditorenkontowartung nicht zugewiesen, und das Kreditorenkonto wird im Fenster Buchungskonten einrichten nicht zugewiesen.
- Das Unternehmen ist für Sicherheit auf Kontoebene registriert. Darüber hinaus verfügt der Benutzer, der die Rückerstattungsprüfungen verarbeitet, nicht über die Berechtigung, die angegebenen Kreditorenkonten im Fenster Kreditorenkontowartung oder im Fenster Buchungskonten einrichten zu verwenden.
- Der Geschäftszeitraum, in dem die Rückerstattung in Kreditorenbuchhaltung in Microsoft Dynamics GP erfolgt, wird geschlossen.
- Bei der Bearbeitung der Erstattungsprüfungen wurde eine Buchungsunterbrechung oder eine Netzwerkunterbrechung durchgeführt.
Ursache oder Szenario 2
Dieses Problem tritt auf, wenn die Buchung einer sonstigen Gebühr, die der Scheck bezahlt, unterbrochen wurde. Die sonstige Gebühr wurde teilweise ohne Einen Betrag gebucht, und die Transaktion verbleibt im Batch.
Lösung
Lösung für Szenario 1
Um dieses Problem zu beheben, ermitteln Sie die Ursache aus der Liste der möglichen Ursachen in Szenario 1 im Abschnitt Ursache , und beheben Sie dann das Problem. Führen Sie die folgenden Schritte aus, um das Problem zu beheben:
- Stellen Sie sicher, dass ein Standardkonto für Kreditorenkonten für den Einkauf in Microsoft Dynamics GP eingerichtet ist und dass das Konto in der Liste Anzeigen im Fenster Buchungskonten einrichten aufgeführt ist.
- Stellen Sie sicher, dass der Benutzer zugriff auf das Kreditorenkonto im Fenster Organisationsstruktur Massenzuweisung hat. Um das Fenster Organisationsstruktur Massenzuweisung zu öffnen, zeigen Sie im Menü Karten auf System, und wählen Sie dann Organisationszuweisungen aus.
- Stellen Sie sicher, dass der Benutzer Zugriff auf das Fenster Kreditorenbuchhaltung hat, indem Sie die reguläre Sicherheit oder erweiterte Sicherheit verwenden.
- Stellen Sie sicher, dass der Geschäftszeitraum, in dem das Dokument gebucht wird, im Fenster "Geschäftsperioden einrichten" unter "Einkauf" den status "Öffnen" aufweist. Um das Fenster Fiscal Perioden Setup zu öffnen, zeigen Sie im Menü Extras auf Setup, zeigen Sie auf Unternehmen, und wählen Sie dann Geschäftsperioden aus.
- Stellen Sie den Überprüfungsbatch zur Verfügung, und stellen Sie dann den RMPMXFR-Batch zur Verfügung. Führen Sie dazu die Schritte unter KB – Ein Batch wird in den status "Posten", "Empfangen", "Beschäftigt", "Markiert", "Gesperrt" oder "Bearbeitet" in Microsoft Dynamics GP gespeichert aus.
- Wenn die Probleme in Szenario 2 auftreten, wechseln Sie zur Lösung für Szenario 2.
Lösung für Szenario 2
Gehen Sie wie folgt vor, um das Problem zu beheben:
Wenn Sie den Überprüfungsbatch noch nicht verfügbar gemacht haben, stellen Sie den Überprüfungsbatch zur Verfügung. Führen Sie dazu die Schritte unter KB – Ein Batch wird in den status "Posten", "Empfangen", "Beschäftigt", "Markiert", "Gesperrt" oder "Bearbeitet" in Microsoft Dynamics GP gespeichert aus.
Nachdem die Dokumente überprüft wurden, entfernen Sie das duplizierte Dokument.
Hinweis
Wenn das Dokument mit dem status Open ordnungsgemäß veröffentlicht wurde und das Dokument, das eine status work aufweist, nicht korrigiert wird, löschen Sie den Batch, um das Doppelte zu entfernen. Wenn das Dokument mit dem status Open beschädigt ist, entfernen Sie das Dokument mit dem status Open, und aktivieren Sie dann die Veröffentlichung des Dokuments mit einer status Work. (Wenn keine Beträge vorhanden sind oder das Dokumentdatum 00/00/0000 ist, kann das Dokument beschädigt sein.) Sie können dieses Dokument mithilfe des folgenden Löschskripts in SQL Query Analyzer oder mithilfe der Supportadministratorkonsole entfernen.
Delete PM20000 where Dex_Row_ID = XX
Hinweis
XX ist ein Platzhalter für die Dex Row ID der sonstigen Gebühr.
Wenn Sie das Dokument für verschiedene Gebühren veröffentlichen müssen, stellen Sie das Dokument bereit.
Nachdem Sie den Überprüfungsbatch wiederhergestellt haben, drucken Sie den Überprüfungsbatch, und veröffentlichen Sie dann den Überprüfungsbatch. Weitere Informationen finden Sie unter KB – Ein Batch wird im status "Posten", "Empfangen", "Beschäftigt", "Markiert", "Gesperrt" oder "Bearbeitet" in Microsoft Dynamics GP gespeichert.
Weitere Informationen
Beachten Sie die folgenden Anforderungen, um Rückerstattungsprüfungen zu verwenden:
- Das Feature "Rückerstattungsprüfungen" muss registriert sein, und Sie müssen sowohl Kreditorenkonten als auch Debitorenkonten in Microsoft Dynamics GP erworben haben.
- Das Fenster "Setup der Rückerstattungsprüfungen" muss konfiguriert werden.
- Der Kreditorendatensatz muss für den Kunden erstellt werden.
- Die Beziehung zwischen dem Kunden und dem Kreditor muss im Fenster Kunden-/Kreditorenbeziehungen eingerichtet werden.
Wenn Rückerstattungsprüfungen verarbeitet werden, geht Microsoft Dynamics GP davon aus, dass der Kunde die Rechnung zu viel bezahlt hat, und fordert das Unternehmen auf, die überschüssige Barzahlung zurückzuerstatten. Wenn Sie die Rückerstattung verarbeiten, wird eine Abbuchungsnotiz erstellt. Die Abbuchungsnotiz wird auf die überschüssige Barzahlung angewendet. Anschließend wird eine sonstige Gebühr erstellt. Die sonstigen Gebühren werden sofort an den Anbieter gebucht. Dieses Dokument für verschiedene Gebühren wird mit einem Scheck für die Zahlung ausgewählt.