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Beheben von Authentifizierungsproblemen in Microsoft 365-Apps, wenn Sie versuchen, eine Verbindung mit einem Microsoft 365-Dienst herzustellen

Symptome

Die Authentifizierung schlägt in einigen Microsoft 365-Anwendungen automatisch fehl, und Outlook wechselt möglicherweise ohne Interaktion in den Zustand "Kennwort benötigen". Wenn Sie einen Web Account Manager-API-Aufruf an FindAllAccountsAsync vornehmen, wird möglicherweise der Fehlercode "-2147024809" in den Microsoft Entra-Protokollen oder den Microsoft 365-Clientprotokollen angezeigt.

Von Bedeutung

Dieses Problem tritt nur auf Computern auf, auf denen Windows 10, Version 1703 oder höher, und Microsoft 365, Version 1807 oder höher, ausgeführt wird.

Ursache

Das Authentifizierungsproblem tritt aufgrund fehlender Paketinformationen über die Active Directory-Authentifizierungsbibliothek (ADAL) oder Live ID auf.

Beschluss

Tipp

Führen Sie die Microsoft 365-Anmeldeproblembehandlung aus, um mehrere gängige Microsoft 365-Anmeldeprobleme zu diagnostizieren und automatisch zu beheben.

Um dieses Problem zu beheben, verwenden Sie PowerShell, um die Pakete für das Microsoft Entra WAM-Plug-In (für Organisations- oder Geschäftskonten) und Live ID (für persönliche Konten wie @outlook.com, @hotmail.comusw.) neu zu installieren. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie in Der Taskleiste mit der rechten Maustaste auf das Windows-Symbol, und wählen Sie dann Windows PowerShell (Administrator) aus.

  2. Wenn Sie von einem Benutzerkontensteuerungsfenster (User Account Control, UAC) aufgefordert werden, wählen Sie "Ja " aus, um PowerShell zu starten.

  3. Wenn es sich bei Ihrem Problem um ein Geschäftskonto handelt, müssen Sie das Microsoft Entra WAM-Plug-In-Paket beheben. Führen Sie den folgenden Befehl in der Befehlskonsole aus:

    if (-not (Get-AppxPackage Microsoft.AAD.BrokerPlugin)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.AAD.BrokerPlugin
    
  4. Wenn Es sich bei Ihrem Problem um ein persönliches Konto handelt, müssen Sie das Live ID-Paket beheben. Führen Sie den folgenden Befehl in der Befehlskonsole aus:

    if (-not (Get-AppxPackage Microsoft.Windows.CloudExperienceHost)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.Windows.CloudExperienceHost
    

Nachdem Sie die Befehle ausgeführt haben und diese ohne Fehler abgeschlossen wurden, wird möglicherweise ein Schnellfortschrittsindikator oder ein Statusergebnis angezeigt, das Informationen zur Paketinstallation enthält.