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Fehler "Fehler in CrmSecurity" beim Genehmigen der E-Mail-Adresse eines Postfachdatensatzes in Dynamics 365

Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie ein Postfach in Microsoft Dynamics 365 manuell genehmigen.

Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4510938

Problembeschreibung

Wenn Sie die Schaltfläche "E-Mail genehmigen" in einem Postfachdatensatz in Dynamics 365 auswählen, wird die folgende Fehlermeldung angezeigt:

In CrmSecurity ist ein Fehler aufgetreten. Wenn Sie sich an den Support wenden, geben Sie bitte die technischen Details an.

Ursache

Dieser Fehler tritt auf, wenn Sie versuchen, die E-Mail als Benutzer zu genehmigen, der nicht über beide der folgenden erforderlichen Rollen verfügt:

  • Globaler Administrator oder Exchange-Administrator in Microsoft 365
  • Sicherheitsrolle "Systemadministrator" in Dynamics 365

Lösung

Standardmäßig erfordert Dynamics 365, dass nur Benutzer mit beiden erwähnten Rollen eine E-Mail-Adresse genehmigen können. Die Systemadministratorrolle in Dynamics 365 oder die Dynamics 365-Dienstadministratorrolle in Microsoft 365 allein reicht nicht für diese Aktion aus.

Weitere Informationen und Anweisungen zum Deaktivieren dieser Anforderung finden Sie unter Entfernen der Anforderung zum Genehmigen von Postfächern.

Weitere Informationen

Wenn Sie in der Fehlermeldung die Schaltfläche "Protokolldatei herunterladen" auswählen, werden Details wie im folgenden Beispiel angezeigt:

Unhandled Exception: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=9.0.0.0, Culture=neutral, PublicKeyToken=<Token ID>]]: System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> Microsoft.Crm.CrmException: The Queue: <Queue ID> email `example@contoso.com` doesn't match with UPN. User <User ID> should be a global administrator to approve mailbox in organization \<organization>.  
at Microsoft.Crm.Dialogs.ApproveEmailAddressDialogPage.ConfigureForm()  
at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)  
at Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e)  
at System.Web.UI.Control.PreRenderRecursiveInternal()  
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)  
at System.Web.UI.Page.HandleError(Exception e)  
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)  
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)  
at System.Web.UI.Page.ProcessRequest()  
at System.Web.UI.Page.ProcessRequest(HttpContext context)  
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()  
at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)  
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean&
completedSynchronously): Microsoft Dynamics CRM has experienced an error. Reference number
for administrators or support: #3A5E4FEADetail:  
<OrganizationServiceFault xmlns:i="https://www.w3.org/2001/XMLSchema-instance" xmlns="https://schemas.microsoft.com/xrm/2011/Contracts">  
  <ActivityId><ID></ActivityId>  
  <ErrorCode> **-2147220970** </ErrorCode>  
  <ErrorDetails xmlns:d2p1="https://schemas.datacontract.org/2004/07/System.Collections.Generic" />  
    <Message>System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> Microsoft.Crm.CrmException: The Queue: <Queue ID> email `example@contoso.com` doesn't match with UPN. User <User ID> should be a global administrator to approve mailbox in organization <organization>.  
   at Microsoft.Crm.Dialogs.ApproveEmailAddressDialogPage.ConfigureForm()  
   at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)  
   at Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e)  
   at System.Web.UI.Control.PreRenderRecursiveInternal()  
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)  
   at System.Web.UI.Page.HandleError(Exception e)  
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)  
   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)  
   at System.Web.UI.Page.ProcessRequest()  
   at System.Web.UI.Page.ProcessRequest(HttpContext context)  
   at
System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()  
   at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)  
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean&amp; completedSynchronously): Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #3A5E4FEA</Message>  
  <Timestamp>2018-12-04T18:17:41.8971683Z</Timestamp>  
  <ExceptionRetriable>false</ExceptionRetriable>  
  <ExceptionSource i:nil="true" />  
  <InnerFault>  
  <ActivityId><ID></ActivityId>  
  <ErrorCode> **-2147220906** </ErrorCode>
<ErrorDetails xmlns:d3p1="https://schemas.datacontract.org/2004/07/System.Collections.Generic" />  
<Message>The Queue: <Queue ID> email `testdl@MyContosoDemo.onmicrosoft.com` doesn't match with UPN. User <User ID> should be a global administrator to approve mailbox in organization <organization>.\</Message>  
<Timestamp>2018-12-04T18:17:41.8981705Z</Timestamp>  
<ExceptionRetriable>false</ExceptionRetriable>  
<ExceptionSource i:nil="true" />  
<InnerFault i:nil="true" />  
<OriginalException i:nil="true" />  
<TraceText i:nil="true" />  
</InnerFault>  
<OriginalException i:nil="true" />  
<TraceText i:nil="true" />  
</OrganizationServiceFault>