Eingehende E-Mails werden unerwartet synchronisiert oder enthalten unerwartete oder fehlende Daten.

Dieser Artikel enthält Informationen zur Problembehandlung für die Probleme bei der Synchronisierung eingehender E-Mails, wenn Sie die serverseitige Synchronisierung in Microsoft Dataverse verwenden.

Eingehende E-Mails werden unerwartet nachverfolgt oder synchronisiert.

Symptome

Die folgende E-Mail wird an einen einzelnen Empfänger in Microsoft Exchange adressiert, wird jedoch sowohl für einen Benutzer als auch für eine Warteschlange aufgelöst, die dieselbe E-Mail-Adresse in Dataverse gemeinsam nutzen.

Screenshot eines E-Mail-Beispiels, das sowohl für einen Benutzer als auch für die Warteschlange aufgelöst wird, die dieselbe E-Mail-Adresse in Dataverse gemeinsam nutzen.

In diesem Fall wird die E-Mail automatisch von Der Warteschlange von Paul Cannon akzeptiert, da sie alle E-Mail-Nachrichten akzeptiert, obwohl die persönlichen Benutzeroptionen von Paul Cannon auf "Keine E-Mail-Nachrichten" festgelegt sind.

Paul Cannons Warteschlange:

Screenshot, der zeigt, dass

Paul Cannons Benutzereinstellungen:

Screenshot der Persönlichen Benutzereinstellungen.

Ursache

Die serverseitige Synchronisierung verfolgt automatisch E-Mails basierend auf der Konfiguration der eingehenden E-Mail-Filtermethode, die für jeden identifizierten (aufgelösten) Dataverse-Empfänger angegeben ist. Ein Dataverse-Empfänger wird aufgelöst, indem die entsprechenden Benutzer- und Warteschlangenpostfächer gefunden werden, die den E-Mail-Adressen zugeordnet sind, die in den Feldern "An", "Cc" und "Bcc " in der empfangenen E-Mail vom externen System (Exchange oder Google Gmail) gefunden wurden. Wenn eine E-Mail-Adresse daher mehreren Dataverse-Postfächern mit unterschiedlichen Einstellungen für eingehende E-Mail-Filtermethoden zugeordnet ist, werden E-Mails möglicherweise unerwartet mit dem System synchronisiert.

Sie können die Felder "An", "Cc" und "Bcc " in "Dataverse" untersuchen, um unerwartete Dataverse-Empfänger zu identifizieren.

Lösung

Wenn eine E-Mail unerwartet mit dem System synchronisiert wird, identifizieren Sie zuerst das Dataverse-Postfach, das die E-Mail automatisch akzeptiert, indem Sie die folgenden Eigenschaften der synchronisierten E-Mail in Dataverse untersuchen.

  • Accepting Entity: The user or queue that receives the email and is configured to automatically track it. Wenn z. B. eine Warteschlange mit dem Namen "Kundendienst", die für die Nachverfolgung aller E-Mails konfiguriert ist, eine E-Mail empfängt, wird die Warteschlange "Kundendienst" als akzeptierte Entität betrachtet.

    Hinweis

    Diese Spalte ist für manuell nachverfolgte E-Mails leer. In diesem Fall können Sie auf die Spalte "Erstellt nach " verweisen.

  • Empfangendes Postfach: Das Postfach, das verarbeitet wird, wenn die serverseitige Synchronisierung erkennt, dass eine E-Mail einen Benutzer oder eine Warteschlange enthält, die für die automatische Nachverfolgung konfiguriert ist.

    Wichtig

    Der Wert dieser Spalte kann sich von der Accepting-Entität unterscheiden. Angenommen, Paul Cannon, der so eingerichtet ist, dass Antworten auf vorhandene E-Mails automatisch nachverfolgt werden, erhält eine Nachricht. Die Warteschlange "Kundendienst", die zum Nachverfolgen aller E-Mails eingerichtet ist, empfängt dieselbe Nachricht. Die serverseitige Synchronisierung kann das Postfach von Paul zuerst verarbeiten und erkennen, dass ein anderer Empfänger , "Kundendienst", so konfiguriert ist, dass die E-Mail automatisch nachverfolgt wird. In diesem Fall ist die Annehmende Entität die Warteschlange "Kundendienst", aber das empfangende Postfach ist Pauls.

Hinweis

Diese Felder werden standardmäßig nicht im E-Mail-Formular angezeigt. Sie können sie dem Formular oder einer Ansicht "Erweiterte Suche " hinzufügen, um deren Werte anzuzeigen. Weitere Informationen zum Hinzufügen von Feldern zur Ansicht "Erweiterte Suche" finden Sie unter Erstellen, Bearbeiten oder Speichern einer Ansicht mithilfe der älteren erweiterten Suche.

Screenshot der Eigenschaften

Nachdem die Akzeptierende Entität identifiziert wurde, können Sie die Methode zum Filtern eingehender E-Mails des Benutzers oder der Warteschlange ändern, um zukünftige Vorkommen zu verhindern. Informationen hierzu finden Sie unter "Festlegen persönlicher Optionen", die sich auf die Nachverfolgung und Synchronisierung zwischen Kundenbindungs-Apps und Outlook oder Exchange auswirken.

Doppelte E-Mails werden nachverfolgt oder synchronisiert

Die serverseitige Synchronisierung kann so konfiguriert werden, dass Benutzer automatisch gesendete und empfangene Kopien derselben E-Mail erstellen können, wenn die E-Mail die Eingehende E-Mail-Filtermethode des Benutzers erfüllt.

So vermeiden Sie doppelte E-Mails, die nachverfolgt oder synchronisiert werden sollen:

  1. Wählen Sie in Dataverse das Zahnradsymbol >"Erweiterte Einstellungen" aus.

  2. Navigieren Sie zu >den Einstellungen für die E-Mail-Konfigurationseinstellungen für die E-Mail-Konfiguration.>

  3. Deaktivieren Sie unter den Optionen zum Festlegen der Nachverfolgung für E-Mails zwischen Microsoft Dynamics 365-Benutzern die Einstellung "Nachverfolgen von E-Mails", die zwischen Dynamics 365-Benutzern gesendet wurden, als zwei Aktivitätenoption .

    Screenshot der Einstellung

Weitere Informationen dazu, wie das System erkennt, ob eine E-Mail automatisch höhergestuft werden soll, finden Sie unter Angeben, welche E-Mails automatisch nachverfolgt werden.

Weitere Szenarien

Die zwischen Dynamics 365-Benutzern gesendeten E-Mails als zwei Aktivitäten sollen auf E-Mail-Nachrichten angewendet werden, die zwischen Benutzern gesendet werden. Auch wenn die Einstellung deaktiviert ist, können doppelte E-Mails weiterhin basierend auf der Methode zum Filtern eingehender E-Mails eines Empfängers erstellt werden, wenn eine Warteschlange ein Absender oder Empfänger einer E-Mail ist.

Es handelt sich um folgende Szenarien:

  1. Eine E-Mail wird von einer Dataverse-Warteschlange an einen Benutzer gesendet.

    Aktivieren Sie zum Beheben dieses Szenarios die Datenbankeinstellung IgnoreInternalEmailFromQueues .

  2. Eine E-Mail wird von einem Dataverse-Benutzer an ein Warteschlangenpostfach gesendet.

    Um dieses Szenario zu beheben, deaktivieren Sie die Datenbankeinstellung "DoNotIgnoreInternalEmailToQueues ".

Weitere Informationen zum Festlegen von Datenbankeinstellungen finden Sie unter Ändern der Standardeinstellungen für die Umgebungsdatenbank.

Weitere Informationen zu verschiedenen Datenbankeinstellungen, die sich auf die serverseitige Synchronisierung auswirken, finden Sie unter "OrgDBOrgSettings" für die serverseitige Synchronisierung.

Alte, vergangene oder historische E-Mails werden unerwartet nachverfolgt oder synchronisiert.

Bei der serverseitigen Synchronisierung wird das Prozess-E-Mail-Datum (ProcessEmailsReceivedAfter) für jeden Postfachdatensatz verwendet, um zu bestimmen, wie weit das System zurück zu E-Mails gehen soll. Dieser Wert wird vom System verwaltet und aktualisiert, wenn neue E-Mails nach dem anfänglichen Onboarding in nachfolgenden Synchronisierungszyklen verarbeitet werden.

  • Wenn Sie ein Postfach zum ersten Mal getestet und aktiviert haben, verwendet das System zunächst das Datum "E-Mail verarbeiten von" (ProcessEmailsReceivedAfter) im zugehörigen E-Mail-Serverprofildatensatz, um das Startdatum für die Verarbeitung festzulegen.

    Screenshot der Einstellung

  • Wenn Sie bereits ein Postfach getestet und aktiviert haben, das ein altes Datum verwendet, können Sie das Postfachformular anpassen und das Attribut "Prozess-E-Mail von " hinzufügen, damit Sie es aktualisieren können, um einen neueren Wert zu verwenden. Das Update wird für den nächsten Zyklus wirksam.

    Hinweis

    Das System verwendet immer den größeren Wert zwischen dem Datum der Prozess-E-Mail von dem E-Mail-Serverprofil und dem Postfach.

Weitere Informationen dazu, wie die Prozess-E-Mail von Datum die Synchronisierung beeinflusst, finden Sie unter Bewährte Methoden für die serverseitige Synchronisierung.

Synchronisierte E-Mails enthalten unerwartete Absender oder Empfängerparteien.

Bei der serverseitigen Synchronisierung wird die E-Mail-Adressauflösung für alle Absender- und Empfänger-E-Mail-Adressen ausgeführt, wenn eingehende E-Mails mit dem System synchronisiert werden. Dazu werden alle Datensätze in Dataverse abgerufen, die einer bestimmten E-Mail-Adresse zugeordnet sind. Wenn eine Übereinstimmung gefunden wird, ordnet das System mindestens einen Datensatz als Aktivitätspartei in der E-Mail zu.

Hinweis

Eine Spalte in Dataverse, die einen Formattyp "E-Mail" aufweist, ist an der Auflösung von E-Mail-Adressen beteiligt.

Screenshot, der den E-Mail-Formattyp einer Spalte zeigt.

Wenn also eine E-Mail-Adresse mehreren Dataverse-Datensätzen zugeordnet ist (z. B. einer E-Mail-Adresse, die zwischen einem Benutzer und einer Warteschlange freigegeben wurde), werden alle aufgelösten Empfänger in ihren jeweiligen Empfängerfeldern angezeigt.

Im folgenden Screenshot ist beispielsweise die E-Mail-Adresse von Paul Cannon sowohl dem Postfach des Benutzers als auch einer Warteschlange zugeordnet. Obwohl die E-Mail-Adresse von Paul Cannon nur einmal in der empfangenen E-Mail in Exchange angezeigt wird, werden beide als Empfänger angezeigt.

Screenshot einer E-Mail-Adresse, die sowohl dem Postfach des Benutzers als auch einer Warteschlange zugeordnet ist.

Weitere Informationen finden Sie unter:

Wenn eine E-Mail-Adresse nicht einem bekannten Dataverse-Datensatz zugeordnet ist, wird die E-Mail-Adresse ebenfalls nicht aufgelöst.

Reihenfolge der Absenderauflösung

Da eine E-Mail nur einen einzelnen Absender haben kann, wenn die E-Mail-Adresse des Absenders mehreren Dataverse-Datensätzen zugeordnet ist, verwendet das System eine Prioritätsreihenfolge, um die Absenderaktivitätspartei zu bestimmen. Weitere Informationen finden Sie unter Zuordnen einer E-Mail-Adresse zu einer Zeile.

Synchronisierte E-Mails haben unerwartete Besitzer

Wenn die serverseitige Synchronisierung eine E-Mail-Nachricht mit Dynamics 365 synchronisiert, bestimmt das System den E-Mail-Besitzer basierend auf einigen Faktoren. Informationen dazu, warum eine E-Mail einen unerwarteten Besitzer hat, finden Sie unter How is an email record owner determined.