Die CDS-Benutzerrolle kann nicht auf Power Automate-Flows, Geschäftsprozessflows oder bedarfsgesteuerte Workflows zugreifen.

Dieser Artikel bietet eine Lösung für das Problem, dass die CDS-Benutzerrolle nicht auf Power Automate-Flows, Geschäftsprozessflows oder bedarfsgesteuerte Workflows zugreifen kann.

Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4562298

Symptome

Benutzer, denen nur die CDS-Benutzerrolle zugewiesen ist, können nicht auf zuvor verfügbare Power Automate-Flows, Geschäftsprozessflows oder bedarfsgesteuerte Workflows zugreifen.

Ursache

Die Rolle "CDS-Benutzer " wird aktualisiert, um die Anforderungen eines Standardbenutzers zu erfüllen, um sicherzustellen, dass er flows verwenden kann, die für diesen freigegeben oder von diesem erstellt wurden.

Lösung

Eine der folgenden Optionen:

  1. Geben Sie die Workflows explizit für Benutzer weiter, die Zugriff darauf benötigen.
  2. Erstellen Sie eine neue Rolle mit den gewünschten Berechtigungen auf Zugriffsebene für die Prozessentität, und weisen Sie sie Benutzern zu, die sie benötigen ("Benutzer", "Team", "Geschäftseinheit", "Übergeordnete/untergeordnete Geschäftseinheit","Organisation").
  3. Ändern Sie die vorhandene CDS-Benutzerrolle in die gewünschte Berechtigung auf Zugriffsebene.