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VM-Gast kann nicht geändert oder aus einer Schutzgruppe im Datenschutz-Manager entfernt werden.

Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie eine Schutzgruppe ändern oder einen virtuellen Computer aus einer Schutzgruppe entfernen.

Ursprüngliche Produktversion: System Center 2016 Data Protection Manager
Ursprüngliche KB-Nummer: 4018988

Problembeschreibung

Wenn Sie versuchen, eine Schutzgruppe zu ändern, die Gäste des virtuellen Hyper-V-Computers (VM) enthält, oder Sie versuchen, einen virtuellen Computer aus einer Schutzgruppe zu entfernen, erhalten Sie eine Fehlermeldung, die etwa wie folgt aussieht:

Fehler beim Entfernen Guest_Name:
Fehler 157: Guest_Name kann dem Schutz nicht hinzugefügt werden, da es bereits Mitglied einer Schutzgruppe ist.

Ursache

Dieses Problem liegt an doppelten Einträgen in der DPM-Datenbank. Die doppelten Einträge können auftreten, nachdem ein geschützter virtueller Computer von einem Hyper-V-Cluster zu einem anderen Hyper-V-Cluster migriert wurde, und diese VM im neuen Cluster erneut geschützt ist.

Lösung

Um dieses Problem zu beheben, wenden Sie sich an Microsoft-Support, um die doppelten Einträge zu entfernen. Um zukünftige Vorkommen zu verhindern, aktivieren Sie die Livemigration. Informationen hierzu finden Sie unter Einrichten des Schutzes für die Livemigration.