Sysprep schlägt fehl, nachdem Sie Microsoft Store-Apps entfernt oder aktualisiert haben, die integrierte Windows-Images enthalten.

In diesem Artikel wird ein Problem behandelt, das auftritt, wenn Sie eine bereitgestellte Microsoft Store-App mithilfe des Microsoft Store entfernen oder aktualisieren und dann sysprep auf dem Computer ausführen.

Gilt für: Windows 10 – alle Editionen, Windows 11
Ursprüngliche KB-Nummer: 2769827

Einführung

Sysprep ist ein Tool für IT-Administratoren, die eine Installation von Windows für Duplizierung, Überwachung und Kundenübermittlung vorbereiten möchten. Die Anleitung in diesem Artikel ist für die Verwendung durch Supportmitarbeiter und IT-Experten vorgesehen. Wenn Sie ein Heimbenutzer sind, bei dem bei der Verwendung von Microsoft Store-Apps Probleme auftreten, lesen Sie Beheben von Problemen mit Apps aus dem Microsoft Store.

Mehrere Microsoft Store-Apps sind in Windows-Images integriert. Zu diesen Apps gehören unter anderem die Apps Mail, Maps, Messaging, Bing, Travel und News. Diese Apps werden als bereitgestellte Apps bezeichnet. Bereitgestellte Apps werden im Image bereitgestellt und sollen bei der ersten Anmeldung für jeden Benutzer des Windows-Images installiert werden. Zusätzlich zu den integrierten Apps können Sie Ihre eigenen branchenspezifischen Microsoft Store-Apps quer in das Windows-Image laden, ohne sie im Microsoft Store veröffentlichen zu müssen. Sie können Pakete querladen Appx , indem Sie Online- oder Offlinewartungsbefehle verwenden, die in DISM.exe oder über das DISM PowerShell-Modul verfügbar sind.

Problembeschreibung

Betrachten Sie dazu die folgenden Szenarien:

Szenario 1

  • Sie erstellen einen benutzerdefinierten Windows 10 oder Windows 11 Referenzcomputer, den Sie als Sysprep und erfassen möchten.
  • Sie möchten einige der bereitgestellten Microsoft Store-Apps (Appx Pakete) von diesem Referenzcomputer entfernen.
  • Führen Sie aus dism -online /Remove-ProvisionedAppxPackage /PackageName:<packagename> , um die Bereitstellung der Appx Pakete aufzuheben.

Wenn Sie den Sysprep-Vorgang in diesem Szenario ausführen, schlägt der Vorgang möglicherweise mit dem folgenden Fehler fehl:

Systemvorbereitungstool 3.14
Schwerwiegender Fehler beim Systemvorbereitungsversuch des Computers

Szenario 2

  • Sie verfügen über ein vorhandenes Windows-Image, und mehrere Microsoft Store-Apps werden quer in das Image geladen.
  • Sie möchten einige der quergeladenen Appx Pakete aus Ihrem Image entfernen und weiter anpassen.
  • Sie starten auf dem Referenzcomputer und führen einen der folgenden PowerShell-Befehle aus, um die Bereitstellung des Appx Pakets zu entfernen:
    • Remove-AppxProvisionedPackage -PackageName <packagename>
    • Remove-ProvisionedAppxPackage -PackageName <packagename>

Wenn Sie den Sysprep-Vorgang in diesem Szenario ausführen, schlägt der Vorgang möglicherweise mit dem folgenden Fehler fehl:

Systemvorbereitungstool 3.14
Schwerwiegender Fehler beim Systemvorbereitungsversuch des Computers

Szenario 3

  • Sie erstellen ein Windows 10- oder Windows 11-Referenzimage.
  • Sie stellen eine Verbindung mit dem Microsoft Store her und aktualisieren dann die integrierten Microsoft Store-Apps über den Microsoft Store.

Wenn Sie den Sysprep-Vorgang in diesem Szenario ausführen, schlägt der Vorgang möglicherweise mit dem folgenden Fehler fehl:

Systemvorbereitungstool 3.14 Beim Sysprep des Computers ist ein schwerwiegender Fehler aufgetreten.

Darüber hinaus werden im SetupErr.log möglicherweise die folgenden Fehlereinträge angezeigt:

<Datum><Uhrzeit>, Fehler SYSPRP-Paket <PackageFullName> wurde für einen Benutzer installiert, aber nicht für alle Benutzer bereitgestellt. Dieses Paket funktioniert im Sysprep-Image nicht ordnungsgemäß.
<Datum><Uhrzeit>, Fehler SYSPRP Fehler beim Entfernen von Apps für den aktuellen Benutzer: 0x80073cf2.
<Datum><Uhrzeit>, Fehler SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.
<Date><Time>, Error [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Fehler beim Ausführen von "SysprepGeneralize" aus C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
<Datum><Uhrzeit>, Fehler SYSPRP ActionPlatform::ExecuteAction: Fehler bei der Ausführung der Aktion; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteActionList: Error in execute actions; dwRet = 0x3cf2
<Datum><Uhrzeit>, Fehler SYSPRP SysprepSession::Execute: Fehler beim Ausführen von Aktionen aus C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
<Datum><Uhrzeit>, Fehler SYSPRP RunPlatformActions:Fehler beim Ausführen von SysprepSession-Aktionen; dwRet = 0x3cf2
<Datum><Uhrzeit>, Fehler [0x0f0070] SYSPRP RunExternalDlls: Fehler beim Ausführen von Sysprep-DLLs der Registrierung und Anhalten der Sysprep-Ausführung. dwRet = 0x3cf2
<Date><Time>, Error [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0x80073cf2

Ursache

Sysprep verfügt über einen zusätzlichen Anbieter, der in Windows hinzugefügt wird, um Pakete zu sauber Appx und das Image zu generalisieren. Der Anbieter funktioniert nur, wenn es sich bei dem Appx Paket um ein Pro-Benutzer-Paket oder ein vom Benutzer bereitgestelltes Paket handelt.

  • Pro-Benutzer-Paket bedeutet, dass das Appx Paket für ein bestimmtes Benutzerkonto installiert wird und für andere Benutzer des Computers nicht verfügbar ist.
  • All-User-Paket bedeutet, dass im Appx Bild bereitgestellt wurde, sodass alle Benutzer, die dieses Bild verwenden, auf die App zugreifen können.

Wenn die Bereitstellung eines im Image bereitgestellten Gesamtbenutzerpakets manuell aus dem Image aufgehoben wurde, aber für einen bestimmten Benutzer nicht entfernt wurde, tritt beim Bereinigen dieses Pakets während des Sysprep-Vorgangs ein Fehler auf. Der Anbieter schlägt auch fehl, wenn ein im Image bereitgestelltes Gesamtbenutzerpaket von einem der Benutzer auf diesem Referenzcomputer aktualisiert wurde.

Fehlerbehebung

Um dieses Problem zu beheben, entfernen Sie das Paket für den Benutzer, der sysprep ausführt, und entfernen Sie auch die Bereitstellung. Gehen Sie hierzu wie folgt vor.

Hinweis

Um zu verhindern, dass Der Microsoft Store Apps aktualisiert, trennen Sie die Internetverbindung, oder deaktivieren Sie die automatische Updates im Überwachungsmodus, bevor Sie das Image erstellen.

  1. Führen Sie die folgenden PowerShell-Cmdlets aus:

    Import-Module Appx
    Import-Module Dism
    Get-AppxPackage -AllUsers | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation
    

Hinweis

  • Überprüfen Sie in der Ausgabe dieses letzten Cmdlets die Benutzer, für die das Paket als Installiert angezeigt wird. Löschen Sie diese Benutzerkonten vom Referenzcomputer, oder melden Sie sich mit diesen Benutzerkonten beim Computer an. Führen Sie dann das Cmdlet in Schritt 2 aus, um das Appx Paket zu entfernen.
  • Dieser Befehl listet alle Pakete auf, die von Microsoft veröffentlicht und von jedem Benutzer dieses Referenzcomputers installiert wurden. Da der Computer sysprepped sein soll, wird davon ausgegangen, dass diese Benutzerprofile das Paket nicht mehr benötigen.
  • Wenn Sie Apps, die zu anderen Herausgebern gehören, manuell bereitgestellt haben, führen Sie den folgenden Befehl aus, um sie aufzulisten:

Get-AppxPackage -AllUsers | Format-List -Property PackageFullName,PackageUserInformation

  1. Entfernen Sie Appx das Paket, indem Sie das folgende Cmdlet ausführen:

    Remove-AppxPackage -Package <packagefullname>
    
  2. Entfernen Sie die Bereitstellung, indem Sie das folgende Cmdlet ausführen:

    Remove-AppxProvisionedPackage -Online -PackageName <packagefullname>
    

Wenn Sie versuchen, eine Wiederherstellung nach einem Updateproblem durchzuführen, können Sie die App erneut bereitstellen, nachdem Sie diese Schritte ausgeführt haben.

Hinweis

Das Problem tritt nicht auf, wenn Sie ein Offlineimage warten. In diesem Szenario wird die Bereitstellung automatisch für alle Benutzer gelöscht. Dies schließt den Benutzer ein, der den Befehl ausführt.

Weitere Informationen

Weitere Informationen zum Hinzufügen und Entfernen von Apps finden Sie unter:

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.