Active Directory-Änderungen werden nicht repliziert
Dieser Artikel bietet eine Lösung für ein Problem, bei dem die Replikation nicht abgeschlossen ist, wenn Sie Änderungen des Active Directory-Diensts auf einen Domänencontroller replizieren.
Ursprüngliche KB-Nummer: 830746
Symptome
Wenn Sie versuchen, Änderungen des Active Directory-Diensts in eine unterstützte Version des Domänencontrollers zu replizieren, wird die Replikation nicht abgeschlossen.
Im Ereignisprotokoll werden möglicherweise Ereignisse angezeigt, die den folgenden ähneln:
Ereignisquelle | Ereignis-ID | Ereigniszeichenfolge |
---|---|---|
NTDS-Replikation | 12:32 | Active Directory hat versucht, einen Remoteprozeduraufruf (RPC) an den folgenden Server auszuführen. Das Timeout des Anrufs wurde abgebrochen. |
NTDS-Replikation | 1188 | Ein Thread in Active Directory wartet auf den Abschluss eines RPC, der an den folgenden Domänencontroller vorgenommen wurde. Domänencontroller: b8b5a0e4-92d5-4a88-a601-61971d7033af._msdcs. Contoso.com Vorgang: Änderungen abrufen Thread-ID: 448 Timeoutzeitraum (Minuten): 5 Active Directory hat versucht, den Aufruf abzubrechen und diesen Thread wiederherzustellen. Benutzeraktion Wenn diese Bedingung fortgesetzt wird, starten Sie den Domänencontroller neu. |
NTDS-Replikation | 1173 mit Fehlerstatus 1818 | Internes Ereignis: Active Directory hat die folgende Ausnahme und die zugehörigen Parameter festgestellt. Ausnahme: e0010002 Parameter: 0 Zusätzlicher Datenfehlerwert: 1818 Interne ID: 5000ede |
NTDS-Replikation | 1085 mit Fehlerstatus 1818 | Internes Ereignis: Active Directory konnte die folgende Verzeichnispartition nicht mit dem Domänencontroller an der folgenden Netzwerkadresse synchronisieren. Verzeichnispartition: <NC> Netzwerkadresse: <GUID-basierter DC-Name> Wenn dieser Fehler weiterhin auftritt, konfiguriert die KCC (Knowledge Consistency Checker) die Replikationsverknüpfungen neu und umgehen den Domänencontroller. Benutzeraktion Stellen Sie sicher, dass die Netzwerkadresse mit einer DNS-Abfrage aufgelöst werden kann. Zusätzlicher Datenfehlerwert: 1818 Der Remoteprozeduraufruf wurde abgebrochen. |
In dieser Situation sehen Sie auch Fehler 1818 in der Ausgabe des repadmin /showrepl
Befehls und in der Ausgabe des repadmin /showreps
Befehls:
DC=Contoso,DC=com
<Sitename>\<DCname> via RPC DC
DC object GUID: <GUID> Last attempt @ <DateTime> failed, result 1818 (0x71a): Can't retrieve message string 1818
(0x71a), error 1815. 823 consecutive failure(s). Last success @ (never).
Ursache
Dieses Problem kann auftreten, wenn Zieldomänencontroller, die remoteprozedurbasierte Replikation (RPC)-basierte Replikation ausführen, keine Replikationsänderungen von einem Quelldomänencontroller innerhalb der von der RPC Replication Timeout (mins)
Registrierungseinstellung festgelegten Zeit empfangen (Der Standardwert ist fünf Minuten, wenn der Registrierungseintrag nicht vorhanden ist). Dieses Problem kann in einer der folgenden Situationen am häufigsten auftreten:
- Sie stellen einen neuen Domänencontroller in die Gesamtstruktur her, indem Sie den Konfigurations-Assistenten für Active Directory-Domäne Dienste aus dem Server-Manager Verwaltungskonsole oder über das
Install-ADDSDomainController
Cmdlet verwenden. - Vorhandene Domänencontroller replizieren von Quelldomänencontrollern, die über langsame Netzwerkverbindungen verbunden sind.
Notiz
- Name des Registrierungswerts:
RPC Replication Timeout (mins)
- Speicherort des Registrierungswerts:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters
- Registrierungswerttyp:
REG_DWORD
Der Standardwert für die Registrierungseinstellung RPC-Replikationszeitüberschreitung (Min. Min.) auf unterstützten Betriebssystemen beträgt fünf Minuten. Wenn ein Zieldomänencontroller, der die RPC-basierte Replikation ausführt, das angeforderte Replikationspaket nicht innerhalb des Zeitraums empfängt, den die Registrierungseinstellung RPC-Replikationszeitüberschreitung (mins) angibt, beendet der Zieldomänencontroller die RPC-Verbindung mit dem nicht reagierenden Quelldomänencontroller und protokolliert ein Warnereignis.
Lösung
Um dieses Problem zu beheben, erhöhen Sie die Bandbreite Ihrer Netzwerkverbindung, damit die Active Directory-Änderungen im Fünf-Minuten-Timeoutzeitraum repliziert werden.
Datensammlung
Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir, die Informationen zu sammeln, indem Sie die unter " Sammeln von Informationen" genannten Schritte ausführen, indem Sie TSS für Active Directory-Replikationsprobleme verwenden.