"The bank country/region assigned to vendor's remit-to address can't be the same as the bank..." error when processing EFTs

Applies to:   Microsoft Dynamics GP
Original KB number:   4044032

Symptom

When processing an EFT batch (in Payables or Receivables), the following error occurs:

The bank country/region assigned to the vendor's remit-to address can't be the same as the bank country/region assigned to the checkbook that's assigned to the batch.

Cause

This issue occurs because of the mismatched field between vendor and checkbook Banking information.

Resolution

Verify that the following three banking information fields match between the Checkbook and the Vendors included the EFT batch:

  • Currency ID
  • Bank Country/Region
  • Country/Region code