"Crystal Print Engine Error 709 The table could not be found" error when you run a custom Crystal Reports report

This article provides resolutions for the issue that you may receive The table could not be found error when running a custom Crystal Reports report in Microsoft Dynamics SL 2011.

Applies to:   Microsoft Dynamics SL 2011
Original KB number:   939712

Symptoms

Consider the following scenario:

  • You are running Microsoft Dynamics SL 2011.
  • You use a custom Crystal Reports report.
  • You log on by using Windows Authentication.

In this scenario, you receive the following error message:

Crystal Reports Helper Application for Solomon IV
Get SQL Query failed Report: C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET.RPT
Crystal Print Engine Error: 709 - Error in File C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET.RPT:

The table could not be found.

Cause 1

This error occurs because the following conditions are true:

  • The Crystal Reports report uses one or more custom tables or custom views.
  • Either the E7F575915A2E4897A517779C0DD7CE Microsoft SQL Server user or the MSDSL SQL Server application role does not have the required permissions to the custom table or to the custom view. See Resolution 1 in the Resolution section.

Cause 2

An Open Database Connectivity (ODBC) connection is set up incorrectly to use Windows Authentication instead of SQL Server authentication. When you first run a Crystal Reports report on a new workstation, an ODBC connection is created for the Microsoft Dynamics SL system database and for the Microsoft Dynamics SL application database. This connection should be set up to use SQL Server authentication, even if you use Windows Authentication to sign in to Microsoft Dynamics SL. See Resolution 2 in the Resolution section.

Resolution 1

Assign the appropriate rights to the custom table or to the custom view. To do this, follow these steps:

  1. Start Microsoft SQL Server Management Studio.
  2. Expand Databases, expand the Microsoft Dynamics SL database, and then expand Tables or Views.
  3. Locate the custom table or the custom view in the list.
  4. Right-click the custom table or the custom view. Then, select Properties.
  5. In the Select a Page pane, select Permissions.
  6. Select ADD, type MSDSL, and then select OK.
  7. For the Select permission, select the Grant check box.
  8. Select ADD.
  9. Select Browse. Then, select the check box next to the E7F575915A2E4897A517779C0DD7CE user.
  10. Select OK two times.
  11. For the Control permission, select the Grant check box.

Resolution 2

To resolve this problem, delete the ODBC connections, and let Microsoft Dynamics SL re-create the connections. To do this, follow these steps:

  1. Select Start, select Settings, and then select Control Panel.
  2. Select Administrative Tools.
  3. Select Data Sources (ODBC).
  4. On the User DSN tab, remove any entries for the Microsoft Dynamics SL system database and for the Microsoft Dynamics SL application database.
  5. On the System DSN tab, remove any entries for the Microsoft Dynamics SL system database and for the Microsoft Dynamics SL application database.
  6. Sign in to Microsoft Dynamics SL again, and then try to use the report again. The User DSN entries should be re-created automatically.