"Crystal Print Engine Error 536" or "System Message 7014" error when you try to print or print preview a custom report in Microsoft Dynamics SL

This article provides multiple resolutions to a problem in which you receive two error messages when you print or print preview a custom report.

Applies to:   Microsoft Dynamics SL
Original KB number:   897023

Symptoms

When you print a custom report or preview a custom report before you print it in Microsoft Dynamics SL, you receive the following error messages:

Crystal Print Engine Error: 536-Error in File. Unable to connect: incorrect log on parameters.

System Message 7014: Report Execution failed with error 536.

Cause

This problem occurs for one or more of the following reasons.

Cause 1

The Trusted Connection parameter in the report file is set to 1. See Resolution 1.

Cause 2

The Open Database Connectivity (ODBC) connection on the workstation is corrupted. See Resolution 2.

Cause 3

The report is pointing to two different databases. See Resolution 3.

Cause 4

The E7F575915A2E4897A517779C0DD7CE sign-in account in SQL Server 2005 or in SQL Server 2008 is disabled, or has an incorrect password. See Resolution 4.

Resolution

To resolve this problem, use the appropriate resolution.

Resolution 1

To resolve this problem, set the Trusted Connection parameter in the report file to 0 (zero). To do it, follow these steps:

  1. Start Crystal Reports 10 for Solomon.

  2. Select Open, select the custom report, and then select Open.

  3. On the Database menu, select Set Datasource Location.

  4. In the Set Datasource Location dialog box, expand Current Data Source: Properties.

  5. Under Current Data Source: Properties, locate the Trusted Connection: 1 parameter.

    Note

    If the Trusted Connection parameter isn't listed, the Trusted Connection option wasn't selected when the report was created, and it isn't the cause of the error.

  6. Right-click Trusted Connection: 1, and then select Edit.

  7. Type 0.

  8. Select Close.

  9. Select Save.

Resolution 2

To resolve this problem, delete the Microsoft Dynamics SL ODBC connections. Then, let Microsoft Dynamics SL re-create the connections. To do it, follow these steps:

  1. Select Start, select Control Panel, select Administrative Tools, and then select Data Sources (ODBC).
  2. On the User DSN tab, remove any items that point to your Microsoft Dynamics SL application databases.
  3. On the System DSN tab, remove any items that point to your Microsoft Dynamics SL application databases.
  4. Rerun the report in Microsoft Dynamics SL. The ODBC connections are automatically re-created when you run a report in Microsoft Dynamics SL.

Resolution 3

To resolve this problem, reset the data source in Crystal Reports. To do it, follow these steps:

  1. Start Crystal Reports 10 for Solomon.
  2. Select Open, select the custom report, and then select Open.
  3. On the Database menu, select Set Datasource Location.
  4. In the Replace With box, expand Create New Connection, and then expand ODBC (RDO).
  5. Select your Microsoft Dynamics SL database, and then select Next.
  6. Enter your sign-in information. Don't select the Trusted Connection check box.
  7. Select Finish.
  8. Select the database in the Replace With box. Then, select the database in the Current Data Source box.
  9. Select Update.
  10. If you have multiple databases in the Current Data Source box, repeat steps 8 and 9 for each database.
  11. Select Save, and then exit Crystal Reports.

Resolution 4

To resolve this problem, enable the E7F575915A2E4897A517779C0DD7CE sign-in account in SQL Server 2005 or in SQL Server 2008, and then run the Synchronize All Ownership & Security update scenario in the Database Maintenance (98.290.00) screen in Microsoft Dynamics SL. To do it, follow these steps:

  1. Start SQL Server Management Studio, and then connect to the server that hosts the Microsoft Dynamics SL databases.
  2. In the Object Explorer pane, expand Security, and then expand Logins.
  3. Under Logins, right-click E7F575915A2E4897A517779C0DD7CE, and then select Properties.
  4. In the Select a page pane, select Status, and then select Enabled under Login.
  5. Select OK, and then close SQL Server Management Studio.
  6. In Control Panel, select Administrative Tools, and then select Microsoft Dynamics SL Database Maintenance.
  7. Connect to the instance of SQL Server that is hosting the Microsoft Dynamics SL databases.
  8. Select the Update Database tab.
  9. In the Update Scenarios list, select Synchronize All Ownership & Security, and then select Update Database.
  10. At the bottom of the Database Maintenance (98.290.00) screen, confirm that the progress bar has finished, and then select Close.