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Dialogs in Microsoft Dynamics CRM 2011 are language-specific

This article provides a solution to dialogs when organizations are using multiple languages.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2701532

Symptoms

A System Customizer creates a dialog in Microsoft Dynamics CRM 2011. The dialog inherits the language settings of the user, and users using a different language in Dynamics CRM can't see the dialog in the dialog list when they try to start a dialog.

Cause

Dialogs contain text for Prompts, Responses, and Tips the feature provides the support to define a language for the dialog. This language setting is honored by the CRM application via the user's language setting.

Resolution

For an organization supporting different language packs, the recommended model is to create separate equivalent dialogs for each language. The users will see the list of dialogs only for their preferred language from within the application.

For organizations that require a single language dialog to be surfaced for its users, whatever their language settings are, the recommended approach would be to customize the ribbon and add a button pointing to the URL of the dialog.