Embedded images in Rich Text emails are not handled correctly by the Email Router or Server-Side Sync in Microsoft Dynamics CRM
This article introduces a by design behavior that embedded images in Rich Text emails are not handled correctly by the Email Router or Server-Side Synchronization in Microsoft Dynamics CRM.
Applies to: Microsoft Dynamics CRM 2011, Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2016
Original KB number: 2934043
Symptoms
Embedded images in Rich Text emails are not handled correctly by the Email Router or Server-Side Synchronization in Microsoft Dynamics CRM.
Cause
This occurs because Microsoft Dynamics CRM requires a unique content ID that isn't used with Rich Text emails. When the Email Router or Server-Side Synchronization asks for this unique content ID to convert the text to HTML, the value is blank and the image cannot be associated back to Microsoft Dynamics CRM.
Status
This is currently by design.