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We're Sorry. Your server is not available or does not support this application. An error occurs when connecting to the CRM app on an iPad or iPhone

This article provides a solution to an error that occurs when you connect an iPhone or iPad to the Dynamics CRM app.

Applies to:   Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2015
Original KB number:   3069747

Symptoms

When trying to connect an iPhone or iPad to the Dynamics CRM app, you may receive the error:

" We're Sorry. Your server is not available or does not support this application."

Cause

SSL certificates generated by some external Certificate Authorities may have problems with the entire certificate chain being trusted when configuring the CRM app on an iPhone or iPad.

More information

Accessing the Microsoft Dynamics CRM site through a web application will work correctly. However, on iOS devices, the SSL certificate configured for AD FS and CRM may be seen as untrusted. You'll see similar certificate-related errors when using iOS apps that render the web pages using UIWebViews and WKWebViews.

The iOS device logs will show:

Authentication: Authentication Interrupted.

It has been encountered when the SSL certificate is a wildcard certificate for the entire domain such as *.contoso.com. The root domain such as https://contoso.com works correctly. Subdomains such as https://crm.contoso.com don't work as expected. Which may be because of compatibility with iOS devices and certificates that list wildcard Subject Alternative Names. It's recommended to test with certificates whose root level includes the CRM subdomain such as *.crm.domain.com.