Microsoft Dynamics SL 2015 stops working after applying Cumulative Update 1 (CU1)
This article provides a solution to an issue where Dynamics SL 2015 stops working after applying Cumulative Update 1 (CU1).
Applies to: Microsoft Dynamics SL 2015
Original KB number: 3064588
Symptoms
Consider the following scenario in Microsoft Dynamics SL 2015:
You apply Cumulative Update 1 (CU1) to a computer that has only the SL 2015 client installed. When you try to start Dynamics SL 2015, you notice the existing shortcut no longer works. Additionally, if you browse the mapped drive to the Dynamics SL program files location and try to start Dynamics SL 2015 by running the MsDynamicsSL.exe, nothing happens or Dynamics SL crashes with the message:
Microsoft Dynamics SL has stopped working.
Cause
The problem occurs because of missing or incorrect registry subkey entries.
Workaround
To work around this issue, edit the appropriate registry entries to add the mapped drive path to the Dynamics SL program files location.
Warning Serious problems might occur if you change the registry incorrectly by using Registry Editor or by using another method. These problems might require you to reinstall the operating system. Microsoft can't guarantee these problems can be solved. Change the registry at your own risk.
Use a registry editor to modify the following registry keys:
HKEY_LOCAL_MACHINE\Software\WOW6432Node\Microsoft\DynamicsSL
. Edit the INSTALLDIR and ParentDirectory subkeys to the mapped drive path location to the Dynamics SL program files.HKEY_LOCAL_MACHINE\Software\WOW6432Node\Solomon\SolomonIV Tools for Visual Basic
. Edit the ParentDirectory subkey to the mapped drive path to the Dynamics SL program files.
For example when Dynamics SL is installed in the default program files location on the server, the SL folder is shared and the Dynamics SL client is installed on a computer that has the S: mapped drive set. Edit the appropriate subkeys to: S:\Applications
.
If you want help, contact Microsoft Dynamics SL technical support.