An invalid argument error occurs when you save any service activity record in Microsoft Dynamics CRM 2011 or 2013
This article provides a solution to an invalid argument error that occurs when you save any service activity record in Microsoft Dynamics CRM 2011 or 2013.
Applies to: Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2011
Original KB number: 2923682
Symptoms
When you try to save any service activity record while the service field is left blank in Microsoft Dynamics CRM 2011 or 2013, you receive an invalid argument error.
Cause
This issue occurs because the service field is designed to be a required field. If the field is left blank, the exception is thrown. This field is required even if the requirement level is changed.
More information
This issue will be fixed in a future release.