"You can't post to a tax period that has not been set up" in Microsoft Dynamics GP

This article provides a resolution for the issue that you can't post on a new Australian installation for Microsoft Dynamics GP.

Applies to:   Microsoft Dynamics GP
Original KB number:   4498538

Symptoms

When trying to post on a new Australian installation for Microsoft Dynamics GP, you receive the following error message:

You can't post to a tax period that has not been set up.

Cause

No tax periods have been set up.

Resolution

Set up the tax periods as follows:

  1. Go to Microsoft Dynamics GP > Tools > Setup > Company > Tax periods.
  2. Select the Year and select Calculate.
  3. Edit dates as needed and select OK.