SharePoint Site owners not getting actual full control

DWTKBrook 41 Reputation points
2022-09-09T17:41:29.63+00:00

I have users in the site owners group who do not have full control privilege's, even though they should have full control listed on the home page when I select group membership I see

239633-image.png

But when I go Site Settings>Site permissions>Site Owners group, I see that the site owners list (below) is a bit different and the Site members list is empty. The users in the Owners group are unable to add new users (no new button)

![239592-image.png][2] [2]: /api/attachments/239592-image.png?platform=QnA

I don't understand why the Site Owners do not have Full control when their permissions sat they do?

Any ideas. Thank you

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
8,099 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Yi Lu_MSFT 17,326 Reputation points
    2022-09-12T08:07:22.713+00:00

    Hi @DWTKBrook
    According to the screenshot you provided, the first group membership is the unified group you created when you create the site which is not a SharePoint group:

    240012-image.png

    As to you mentioned that "Site Settings>Site permissions>Site Owners group, I see that the site owners list (below) is a bit different and the Site members list is empty. The users in the Owners group are unable to add new users (no new button)", this is by design, we could not add SharePoint group member here:

    240002-capture.png

    Instead, you need to add members to group here:

    239889-image.png

    239948-image.png


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.