question

BenjaminEvenson-6091 avatar image
2 Votes"
BenjaminEvenson-6091 asked Lucas-3270 edited

Drag and dropping email from outlook desktop to Edge doesn't populate dataTransfer API in certain cases

Hi,

I've noticed if an email inside the outlook desktop client meets the following criteria

  • has importance, and

  • has a colon in the Subject

Example: "FW: ATT: This breaks the dataTransferAPI"

When dragged directly from the client to Microsoft Edge(87.0.637.0) The dataTransfer API picks it up as "uri-list" instead of a file, see screenshot below
26130-image.png


ms-edge
image.png (8.5 KiB)
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

I can't reproduce the issue. I test with this email with Outlook 2016 desktop:

26326-untitled.png

When I drag and drop it to Edge Dev (87.0.637.0), the DataTransfer API shows ["text/plain", "Files"] and FileList {0: File, length: 1}: You can check the Test Result.

Which version of Outlook desktop are you using? Besides, please provide the code sample that you test the DataTransfer API so that we can have a test and see how to help.

Regards,
Yu Zhou

1 Vote 1 ·

I've also experienced this with certain emails.
Seems a similar bug report has been submitted to Chrome: https://bugs.chromium.org/p/chromium/issues/detail?id=1127989

1 Vote 1 ·

Hi @YuZhou-MSFT
I have the same problem over edge and chrome browser.

I have Outlook 2019 desktop installed Edge and Google Chrome Versión 91.0.4472.114 (Build oficial) (64 bits).

These are my error cases. this happening when email have a single sender name.

Case 1
From = TestName
Subject = RE: test subject
Received = 11:25 PM
Size = 72 KB
Categories =

Case 2
From = TestName
Subject =
Received = 11:24 PM
Size = 72 KB
Categories =

java script debug:
109215-capture2.png


0 Votes 0 ·
capture2.png (10.9 KiB)

1 Answer

Lucas-3270 avatar image
0 Votes"
Lucas-3270 answered Lucas-3270 edited

Looks like this bug has been fixed recently in edge.
It's fixed for me in version 100.0.1185.44
Previously affected emails now provide a uri-list as well as a file.

I'd appreciate it if anyone knows which version of edge included this fix. @YuZhou-MSFT

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.