Cannot use subsystems in windows 11

Abhinav Kumar 1 Reputation point

Hello, I have a surface laptop 3 running the latest version 22h2 of windows 11, and they released the new features update with tabs in file explorer and everything. among that is the amazon store features allowing us to use android apps in windows however I installed the subsystem but cannot use it as it says to enable virtualization. I checked the task manager it shows virtualization is enabled and I cannot find anything in BIOS. I open windows features and turn on the Virtual machine platform and windows hypervisor platform and they ask for a restart. When I restart they are not checked and are disabled again no matter how many times I try and it disables search indexing as well. Along with that, I can't see the Hyper-v option in my windows features and I have tried the PowerShell command to install it but it shows an error. I have tried almost every step out there.
In the end, no matter what I try I can't turn on virtualization in any way and cannot use subsystems I tried using Linux subsystems as well still it didn't work.

I cannot use the new feature of getting android apps unless I fix it and it was the main highlight of windows 11.

Can someone please help me in the process and guide me?

Thank You

A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,055 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
6,727 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 43,226 Reputation points

    Hello there,

    If the issue is after the recent update i would suggest you to uninstall the new update and see if that helps. If this is caused by update you can then report it to the Microsoft team.

    The Feedback Hub app lets you tell Microsoft about any problems you run into while using Windows . You can also send suggestions to help us improve your Windows experience.

    Send feedback to Microsoft with the Feedback Hub app

    In most cases where virtualization won't work, even if your CPU supports it, the cause is that you have the feature disabled in your computer's BIOS or UEFI. Though most modern computers support virtualization, it often comes disabled by default.


    --If the reply is helpful, please Upvote and Accept it as an answer--