Azure - There is no such global user or group

Ernie Clark Management 1 Reputation point

Take existing machine. Remove from local AD domain, dropping it into workgroup. Reboot. Then add to Azure AD per:

Reboot. Wait many hours for any sync issues.

Check and confirm that machine shows it is in AzureAD by looking in Settings/Accounts/Access work or school.

Note that the account used to add machine to AzureAD should be shown as admin, but no accounts show under Settings/Accounts/Other users under either work or school users nor other users.

I have tried adding many different valid AzureAD accounts under both Work or School User and Other users with no success. Errors are, respectively:
Work or School user: That work or school account could'nt be found. Check the account name and try again (this should work but does not)
Other users: Looks like this isn;t a Microsoft account. Try another email or sign up for a new one.

I have also tried adding a user via command line per:

Launch Command prompt as administrator
Net localgroup Administrators /add "AzureAD\<users Office 365 Email Adddress>"

In all attempts, I get the error: There is no such global user or group: <users Office 365 Email Adddress>

I have tried many different valid users in my AzureAD, tried adding standard users and administrative users all with no success. I have successfully done this on multiple other machines and most have worked fine.

Note, that the account that DOES get authenticated during adding the machine to the AzureAD does not authenticate at any point afterwards. Nor, as I mentioned above, does it show up as a valid user.

Finally, i cannot log in as any user in the AzureAD on this machine - all attempts get the result: The user name or password is incorrect. Try again.

Help, and thanks kindly in advance for any assistance.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
17,532 questions
{count} votes