Blob Storage will not trigger Azure synapse pipeline

Álvaro Ferrer 6 Reputation points


Please help!
We're trying to set up a basic workflow whereby an App Function creates a storage blob, and this event triggers a pipeline in Azure Synapse.

We're unable to trigger an Azure synapse pipeline based on a blob creation event after having read through every blog and tutorial.

The pipeline works when the file is uploaded manually, but NOT when the file is created via an App Funciton. Maybe an access/IAM issue but we're unable to find it.

Things we've tried:

  • Activating Event Grid and Data Factory Resource groups
  • Giving Synapse access to blob storage
  • Assigning and re-assigning the trigger the trigger to the pipeline in synapse

It might be obvious but we're out of ideas.
This is the pipeline:

This is the Cloud Function:

Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,099 questions
Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
3,827 questions
Azure Event Grid
Azure Event Grid
An Azure event routing service designed for high availability, consistent performance, and dynamic scale.
280 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Álvaro Ferrer 6 Reputation points

    Hi @PRADEEPCHEEKATLA-MSFT , no we have not. As we mentioned, we changed our workflow and worked around this issue.
    Also, we don't have a support plan on our current tier.
    Happy to close this ticket when you find suitable.

    Thanks for your help

    1 person found this answer helpful.
    0 comments No comments

  2. Nandan Hegde 27,391 Reputation points MVP

    Can you check the content type of the file:

    usually when that is blank, event trigger is not initiated