Can connect to SSTP VPN but can't interact with Windows Server

Tomáš Pokorný 1 Reputation point
2022-10-24T15:47:01.027+00:00

Hi all,

we use a single server (Windows Server 2019 Essentials) in our micro-sized business. The server's role are Domain Controller, DNS, DHCP and some others.

We also have a MikroTik router. This is our only router and is connected to the internet directly - it's the main gateway to our network and functions also as a firewall.

I managed to configure a SSTP server on the router and I am able to connect to it from a distant network using a Win 10 client.

I can ping the Windows Server's IP address. But I can't do anything else...

Can't ping the server hostname  
Can't access shared files  
Can't do anything else on the server, basically just ping its IP  

Needless to say, this all works when I'm connected directly to the network.

The server handles the DHCP, however when I configured the SSTP on MikroTik, I had to assign some IP Pool to VPN clients. As I am fairly new to MikroTik, I'm not sure if I did everything correctly here. The Windows Server DHCP assigns range 192.168.100.100-192.168.100.254 and I configured the VPN Pool on Mikrotik to 192.168.101.100-192.168.101.254.

The question is - why isn't Windows Server letting me in from the VPN subnet? If I can ping its IP, it means that I am successfully in the network.

I tried to turn off Windows Firewall on the server, but that didn't do anything.

I would appreciate any tips about why this might be happening.

Thanks,
Tomas

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
11,135 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,190 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Jiří Počta 1 Reputation point
    2022-10-25T08:49:39.33+00:00

    I have a similar problem, previously SSTP worked fine. Today in the middle of my work it stopped working, I'm still connected but I can't PING anywhere, not even DC or GW etc.
    I have a backup VPN via OpenVPN that works without a problem. My guess is that the problem is in the VPN service, some faulty Win Server 2019 update ?

    0 comments No comments

  2. Jiří Počta 1 Reputation point
    2022-10-25T09:44:18.473+00:00

    I'm ashamed...
    All it took was a few OS reboots, updates OS, and another OS reboot. VPN (SSTP) works again... I don't understand...

    0 comments No comments