Sharepoint 2016 site keeps asking for Credentials

rpc24 11 Reputation points
2022-10-30T09:29:38.697+00:00

Hello Everyone,
I have a Sharepoint site (with Anonymous access enabled) hosted in Azure server. Whenever I access the backend Site contents page(or any CMS admin pages), its keeps prompting for credentials even though I enter the correct username and password. This issue is happening only outside the server. Inside the server if I supply credentials once for the same site ;it accepts and I am able to view the site contents page. Its an internet based Sharepoint site hosted in AZURE. The issue started appearing since 2 days back. Before that it was fine and used to take the login details. Could anyone guide me what could be the root cause for this issue. I checked the log file, no error messages captured related to this issue.

Regards,
RPC

SharePoint Development
SharePoint Development
SharePoint: A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.Development: The process of researching, productizing, and refining new or existing technologies.
2,807 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Jinwei Li-MSFT 4,726 Reputation points Microsoft Vendor
    2022-11-01T07:14:05.743+00:00

    Hi @rpc24 ,

    1. In Internet Explorer, go to ‘Tools’
    2. Click on ‘Internet Options’
    3. Open the Security tab, then click on the “Trusted Sites” Zone
      255954-image.png
    4. Add SharePoint Site’s URL to the Trusted sites zone. (Make sure you are adding FQDN to the site. E.g. Add: https://SharePoint.Crescent.com rather “*.Crescent.com” )
    5. Now, Click on the ‘Custom level’ button
    6. Scroll down to the bottom and select ‘Automatic logon'
    7. Click OK
      255880-image.png
    8. The next time you log on, select “Remember my password”.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. rpc24 11 Reputation points
    2022-11-01T07:25:38.223+00:00

    Hi JinweiLi-MSF,

    Idid the above steps before, but it hasn't helped. Kindly note this issue is happening since from 2-3 days onwards; before it was fine and it was prompting for credentials only once when we access the backend pages. But now its repeatedly asking for credentials even though we supply the correct details and again this issue is only happening outside the server. If we access the site within server browser there is no such repeated prompting for username and password.