Cloud Services-classic Migration to ARM failed

Adonis Briceno 46 Reputation points
2022-11-01T13:18:27.863+00:00

Hello everyone hopefully someone could help me a bit with this....

While executing the migration of a classic Cloud service (worker Role single instance only, no web role) the process failed during Prepare stage with the error as per the screen shot below:

256133-image.png

the text of the error is:

Unexpected error encountered while preparing migration. Click here to create a new support request. The error was: _errorData: undefined _sourceErrorLevel: undefined
baseTypes: ["MsPortalFx.Errors.AjaxError","MsPortalFx.Errors.Error"]
code: undefined
data: {"uri":"https://management.azure.com/subscriptions/SOME-ID/resourceGroups/SOME-RES-GROUP/providers/Microsoft.ClassicCompute/domainNames/SOME-CLOUD-SERVICE-CLASSIC/slots/production/operationStatuses/SOME-ID?api-version=2017-11-15&return-path=","type":"GET","pathAndQuery":"","requestId":"SOME-ID","failureCause":"","sessionId":"SOMEID","commandName":"Microsoft_Azure_CloudServices.classicVNet_prepareMigration","status":409,"statusText":"error","duration":233.39999997615814}
errorData: undefined
errorLevel: 2
errorThrown:
extension: Microsoft_Azure_CloudServices
handled: undefined
innerErrors: []
jqXHR: {
"readyState":4,
"responseText":"{\
"error\":{\"code\":\"OperationFailed\",\
"message\":\"The operation '75931316adc032a1942721538ae4d0ad'
failed: 'The server encountered an internal error. Please retry the request.'.\"}}",
"responseJSON":{
"error":{"code":"OperationFailed",
"message":"The operation '75931316adc032a1942721538ae4d0ad' failed: 'The server encountered an internal error. Please retry the request.'."}
},"status":409,"statusText":"error"}
message: ajaxExtended call failed
name: AjaxError
source: undefined
stack: AjaxError: ajaxExtended call failed
at r.t (https://portal.azure.com/Content/Dynamic/\_L17QU2UH4Uj.js:73:895)
at new r (https://portal.azure.com/Content/Dynamic/BDJBMIXzdKsk.js:18:1270)
at t.reject (https://portal.azure.com/Content/Dynamic/BDJBMIXzdKsk.js:41:14308)
at Object.<anonymous> (https://portal.azure.com/Content/Dynamic/BDJBMIXzdKsk.js:41:14091)
at a (https://portal.azure.com/Content/Dynamic/\_L17QU2UH4Uj.js:33:39310)
at l (https://portal.azure.com/Content/Dynamic/\_L17QU2UH4Uj.js:33:39622)
textStatus: error
timestamp: 2308054
type: MsPortalFx.Errors.AjaxError

Azure Cloud Services
Azure Cloud Services
An Azure platform as a service offer that is used to deploy web and cloud applications.
664 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Adonis Briceno 46 Reputation points
    2022-11-03T09:41:43.44+00:00

    Hope this helps someone else

    This is a rather simple error with an even simpler solution, BUT the error message does not explicitly indicates that this is the issue.

    For this error, the cause was that the ServiceName and the WorkerRole name were the same, which for some reason is not allowed during the migration process and was/is the cause of failure.

    The solution was to redeployed the cloud service changing the name of the service to a different value to the worker role and that worked.
    The migration worked as expected.

    1 person found this answer helpful.
    0 comments No comments