unable to figureout why there is more than one directory and tenant under my azure active directory

ArunRaaman 996 Reputation points
2022-11-02T01:35:32.393+00:00

Hello There,

I recently started learning Azure Data Factory; as part of my learning process, I created Azure (free) account.

I created a azure devops account for git repository management; further tried to connect active directory from Organization Settings (within Azure DevOps/GitRepistory account). This is where I problem encountered with the error as shown in the screenshot below:

256176-image.png
256205-image.png

I browsed users in Azure Active Directory, where there is only one user with type:'member' (between member and guest) as shown in the screenshot below:

256169-image.png

Next, I browsed into directories of 'Azure Active Directory', and I discovered additional tenant under 'manage tenant' within the 'Azure Active Directory ' (attached a screenshot of it). I believe, somewhere in this process, I created a tenant in my azure account. Following is the screenshot of 'Manage Tenant':

256263-image.png

Also, under switch directory, I found two directories, which is again confusing (that can be understood from the screenshot below):

256175-image.png

I believe, I messed up with some operations. I did some investigation over google and 'azure community', but failed to find a tip to understand it.

I tried to delete the tenant 'diwakarlearningca', but unable to do so (with error message: known issue exist where some enterprise applications are not capable to delete within the portal).

Would anyone help me understand the scenario?

Thank you for your time and efforts.

1: /api/attachments/256174-image.png?platform=QnA 4: /api/attachments/256167-image.png?platform=QnA

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,597 questions
{count} vote

1 answer

Sort by: Most helpful
  1. David Broggy 5,701 Reputation points MVP
    2022-11-02T14:11:45.903+00:00

    Hi Arun,
    Your domains are defined under 'Custom Domains'. Do you have more than one entry in here?
    As long as you've attached to the appropriate tenant and you can see your domain listed, and you're a global admin or appropriate role for adding guest users, it should work.
    I'd suggest starting from a private/incognito browser to be sure you're logging into your test tenant.

    256390-image-2022-11-02-09-09-51.jpg

    2 people found this answer helpful.