cant enable visual studio 2022(community) themes

Aiden Thurston 11 Reputation points
2022-11-02T12:26:53.987+00:00

i have visual studio 2022 community and i downloaded themes from the store, theyre not showing up. ive completely turned off my pc and it still isnt there, ive looked up solutions and all of the microsoft help solutions for other people were just marked as complete with no answer given.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
35,817 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Aiden Thurston 11 Reputation points
    2022-11-03T06:17:15.697+00:00

    it seems to work after using admin privileges on "C:\Program Files\Microsoft Visual Studio\2022\Community\Common7\IDE\CommonExtensions\Platform" even though that makes no sense. fixed.

    1 person found this answer helpful.

  2. PTwr 0 Reputation points
    2024-04-03T18:52:17.81+00:00

    The issue is somewhere in user profile and/or privileges of Visual Studio config folders.

    Fix: run VS as admin and install some extensions from its manager, restart VS, confirm that it works. Wooosh, now it works outside admin as well.

    In my case it was broken on freshly installed W11 with freshly installed VS2022C, but Windows went through obligatory debloating and user was recreated as local admin. I have only tried Theme extensions, but from what I know of vsix extensions after writing some all extensions should have the same stupid issue as it appears to be loading error caused by folder privileges.

    On DeveloperVM it works perfectly fine on local user, so that alone should not be an issue.

    It is not the first time such issue has occurred, with same run-once-as-admin fix. Years ago TFS needed same treatment on first run on every computer my team used. It was back on VS ~2010 on Win7/8, but extensions system has hardly changed since then.

    0 comments No comments