Unable to connect to adls gen2 from azure ml workspace

M, Murugeswari (Cognizant) 456 Reputation points
2022-11-02T15:37:26.37+00:00

Hi,

I tried to create datastore in azure ml to connect to adls gen2. I have created app registration and used those client id and secret id. I also assigned the required permission [ storage blob data owner for the client id] in the resource group where the adls gen2 is located

But still I am not able to access the data. Please suggest me what further I have to do

Thanks

Azure Data Lake Storage
Azure Data Lake Storage
An Azure service that provides an enterprise-wide hyper-scale repository for big data analytic workloads and is integrated with Azure Blob Storage.
1,420 questions
Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,708 questions
{count} votes

1 answer

Sort by: Most helpful
  1. M, Murugeswari (Cognizant) 456 Reputation points
    2022-11-03T12:55:34.46+00:00

    Hi @romungi-MSFT

    Thanks for the reply. The issue is resolved now

    I have mentioned the path wrong and datastore also couldn't directly read my data

    256807-image.png

    Then I came to know that path name should starts after the file system name. After changing my path [ similar to source-data/abc.csv] it worked fine

    Thanks

    1 person found this answer helpful.
    0 comments No comments