How do I get rid of previously used Anchor Attribute?

David Turner 26 Reputation points
2022-11-02T19:19:21.473+00:00

I configured anchor attribute to be ExtendedAttribute10 in error the first time I ran through the Azure ADConnect wizard not knowing exactly what it meant.

I have since uninstalled Azure AD Connect and waited 24 hours and then tried to install it on a different domain controller but when it goes through the wizard again (custom) it still shows this attribute is being used as the anchor.

So the uninstall doesn't seem to be resetting everything despite deleting the ADDConnect directory and SQL folders post uninstall.

Is it set somewhere in Azure AD and how can I reset it back to default so I can re-run the wizard correctly this time please?

thanks in advance

Dave

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,515 questions
0 comments No comments
{count} votes

6 answers

Sort by: Most helpful
  1. David Turner 26 Reputation points
    2022-11-02T21:19:34.44+00:00

    So I think I found a solution, I was looking for some PowerShell command or something but it was a lot simpler than you might think.

    Uninstall and cleanup folders on DC and remove domain accounts and cleanup any objects sync'd to Azure including delete users.

    Go through a custom run of Wizard again and at 'Source Anchor' option change manually to be ObjectGUID.

    Wizard completed ok and after a full sync checking the source anchor it shows as ObjectGUID.

    1 person found this answer helpful.
    0 comments No comments

  2. Andy David - MVP 144.7K Reputation points MVP
    2022-11-02T19:27:51.313+00:00

    Here is a possible solution:
    https://techcommunity.microsoft.com/t5/azure-architecture/azure-ad-connect-procedure-to-change-source-of-anchor-from/m-p/1782331

    I would also consider opening a case with Azure support to assist and/or confirm these steps

    0 comments No comments

  3. David Turner 26 Reputation points
    2022-11-02T19:30:50.95+00:00

    Wow you are on fire today Andy - thanks. I have read that already and can't find anything to help online. As I've tried the uninstall multiple times on different CDs in must in Azure itself so I'm going to create a support case. Will post any useful details here.

    Thanks again

    Dave

    0 comments No comments

  4. Manu Philip 17,271 Reputation points MVP
    2022-11-02T19:41:44.97+00:00

    Here is what Microsoft documentation says about changing the source anchor attribute (plan-connect-design-concepts

    256524-image.png

    I suggest you run the AADConnect wizard with SkipLdapSearch switch to see if it helps

    AzureADConnect.exe /SkipLdapSearch  
    

    ----------

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    0 comments No comments

  5. David Turner 26 Reputation points
    2022-11-02T19:51:39.537+00:00

    Thanks but that didn't help

    256506-screenshot-2022-11-02-at-35025-pm.png